Help with pihole and openwrt

I’m using OpenWrt on my router and have setup two interfaces in addition to the default WAN and WAN6:

  • LAN- configured two wireless networks (2.4 and 5ghz). This is my “stable” interface. Subnet 192.168.1.1/24
  • Guest- also configured two wireless networks, used for experimental stuff. Subnet 192.168.3.1/24

I then setup DNS over TLS following this guide.. Everything was working a-ok. Then I decided I wanted to give pihole a try on my guest interface. I performed the following steps:

  • gave my Pi a static IP address of 192.168.3.201
  • configured my pi to connect to my guest network
  • setup pi-hole: cloudflare upstream, ip address 192.168.3.201/24, gateway 192.168.3.1

Once setup was complete I ran the following:

  • ping 192.168.3.1: destination port unreachable. If I run this command on another client that is connected to my stable network, everything works fine.
  • ping yahoo.com: worked fine.

I then decided to carry on and follow #2 of this guide and set the DHCP option in my guest network to 6,192.168.3.201. I went ahead and changed pihole to point to the router instead of Cloudflare and it’s working.

Why does this work? I want my pihole to use Cloudflare but now it seems it’s going to use whatever the router is using. Is this what I actually want? Additionally, how can I get this working for ipv6? When I setup pihole it did show me an ipv6 address.

Check whether you configured your gateway correctly. If the gateway is incorrect, it makes sense that the Pi-hole can reach all devices inside your network (incl. the router as upstream destination) but no sources outside of your network (such as the CF servers).

Everything does work, but I’m confused why and I’m not of the data flow and how my PiHole is being used. The guide says change dnsmasq to point to PiHole, then it says change PiHole to point to using the router’s DNS. Why do I need to change to the router’s DNS?

Please generate a Pi-Hole debug log, upload when prompted and post the token here. We can take a look at your Pi-Hole configuration and operation.

1yidin250q

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.