Help with Pihole and DD-WRT settings: Pihole shows only one client connected ( the router)

Hello everyone, I apologize if my questions have been asked and posted here before. I am not an experienced user so I would appreciate the help.

I have a Netgear 6700v3 router running DD-WRT and I am trying to use a pihole on my network but I keep getting the following issues over and over no matter how many times I have tried to install a fresh pihole installation on raspberry pi 3 or raspberry pi 4 or even on my openmediavault using docker.

Expected Behaviour:

  1. a list of Individual clients to be listed on the pihole web interface

  2. Pihole web interface to load up

Actual Behaviour:

  1. The pihole dashboard shows only one client connected which is the router and all DNS requests are coming from the router instead of listing individual clients.
  2. The pihole web interface is not reachable or extremely slow in loading. This happens frequently and randomly regardless of the hardware i am running the pihole on. Which tells me that it must be something that I am doing wrong. The strange part is that while the interface does not load or extremely slow to load, the pihole is functioning properly and logging DNS requests.

Please see below my current settings on the router and on the pihole:

The setting on my dd-wrt router are as follows: ( also see attached screenshots)

DHCP server: enabled

router IP address is 192.168.11.11

Static DNS1: 192.168.11.75 ( this is the pihole ip address)

Static DNS2: 9.9.9.9

Static DNS3: 1.1.1.1

Use DNSMasq for DNS: enabled

DHCP-Authoritative: enabld

Forced DNS redirection: enabled

Under the SERVICES tab:

I have Dnsmasq enabled

No DNS Rebind enabled

Query DNSin strict order enabled

Additional Dnsmasq Options: dhcp-option=6,192.168.11.75

DHCP IP Range is :

Start IP Address
192.168.11.12

End IP Address
192.168.11.61

The pihole settings are attached. DHCP is disabled on the pihole.
Only custom DNS is selected on the pihole interface and it is set to the router’s IP address

What I am trying to achieve is to have the pihole display each client individually on its web interface.

And if anyone might have a clue why the pihole web interface is extremely slow when loading or sometimes does not load at all.

Thank you all in advance for the help. Much appreciated

1 Like

Your additional Dnsmasq setting conflicts with the other DNS settings. It says to only send the Pi-hole’s IP for DNS, while the other settings say to use multiple IP addresses. Try disabling Dnsmasq (including “Use DNSMasq for DNS”) and only using Pi-hole for DNS.

Why do you have the Pi-hole forward queries to the router? It can directly use whatever external DNS server you want.

Hello and thanks for your reply.
To answer your question, I was following the steps from this link:

I followed the steps in method number 2.

I would appreciate it if you can please elaborate on how to achieve the following as I am not an experienced user.

What I am trying to achieve is this:

  1. Have all connected devices on my network to strictly go through the pihole for DNS requests. I do not want any request to go through my ISP DNS at all.
  2. Have the pihole list all connected clients individually so I can see the traffic/requests from each device separately.
  3. Finally, I would like to use a third party DNS for my upstream but the third part DNS is not listed as one of the “Upstream DNS Servers” on the pihole’s Web Interface under DNS tab.

Thank you in advance

  1. If you set up the DHCP on the router properly, then all connected clients will receive the DNS of Pi-Hole and nothing else. This is the normal method.

  2. If your router supports it, the IP of each client will be shown in Pi-Hole. You may have to use conditional forwarding in the Pi-Hole. Another option is to use the Pi-Hole as your DHCP server (this will solve problems 1 and 2).

  3. You can list any upstream DNS server you want in the custom fields. Example shown below for unbound on a local port. For commercial upstream servers, use port 53 at the end, not 5353.

image

Hi jfb -
I tried to disable dhcp on the router and enabled it on the phole but I ran into a problem where smartphones could not obtain an IP address and could not get internet, however, all other devices, like PC, TV, PS4 were able to obtain an IP address.

Also, I could not make the pihole to use the DNS servers that I specified in the Custom Upstream DNS server. I used two custom DNS servers in Custom 1 and Custom 2 but the pihole kept on using the ISP DNS.
Sometimes when I ran a DNS test I saw a mixture of DNS servers being used in the results. It contained the two custom DNS servers I plugged into the pihole as well as the ISP DNS.

Any idea on these two issues?

Thanks