Had to transfer Internet service to AT&T Fiber and now have to use their shitty Arris BGW210 modem in front of my other routers. Now my Pi-Hole isn't working even with the modem in pass-through mode

The issue I am facing:

My Pi-Hole won't connect to the Internet properly. It can ping anything, but it can't sudo apt update or even pihole -r without getting connection refused errors.

Previously, my AmpliFi router had been plugged directly into a Google Fiber modem / fiber jack and the whole network and PiHole worked flawlessly. All I had to do was give the Raspberry Pi a fixed network address and put that in the DNS field in the AmpliFi router settings.

Now as soon as I put AT&T's shitty BGW210 modem in front of my AmpliFi router, the Pi-Hole starts acting weird and breaks the network until I remove it as the DNS provider on my router.

The Raspberry Pi itself is also acting weird too. It can successfully ping or any other web address , but fails when I try to sudo apt update (says Err:1 https://deb.nodesource.com/node_14.x buster InRelease Temporary failure resolving 'deb.nodesource.com' ).

When I try to update gravity, it gives errors like [i] Target: https://v.firebog.net/hosts/Easyprivacy.txt [✗] Status: Connection Refused for every single target on the list.

Running pihole -r returns the error Retrieval of supported OS list failed. dig failed with return code 10. Unable to determine if the detected OS (Raspbian 10) is supported no matter which of the two repair options I choose.

Looking at the log brings up a bunch of BOGUS requests, as shown below. I'm not sure why, but I bet it's part of the problem.

Details about my system:

  • AT&T fiber jack --> Arris BGW210 [in pass-through mode] --> AmpliFi Instant Router --> Gigabit switch -> Raspberry Pi (+ rest of network)

  • I am unable to disable the DHCP Server setting on the AT&T modem without all devices being forcibly disconnected and unable to reconnect without a factory reset.

What I have changed since installing Pi-hole:

  • Pi-Hole is also running Unbound/DNSMasq for DNS caching
  • Also installed Homebridge for smart home stuff

Debug Info:
Because of these issues, I can't upload a token from pihole -d output. I've placed it in an unlisted paste bin with the sensitive info redacted, and I can private message anyone who thinks it'll help.

What nameserver is the Pi-hole host using? The following command will show this. If it's (the loopback IP), then it's using Pi-hole. If Pi-hole is misbehaving, then you will need to edit this file and change the nameserver to something other than Pi-hole (i.e. Cloudflare or Quad9) and try the repair again.

cat /etc/resolv.conf

You were right: the nameserver was I changed it to and rebooted, realized it gets overwritten on reboot, then set it back again and tried to sudo apt update and it worked.

I'm not sure what to do now, though. I ran pihole -d and now it uploaded successfully at least: https://tricorder.pi-hole.net/haejhwzdjr

Your debug log shows a few problems. First, your network IP range may have been changed with this new router.

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the eth0 interface: does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)

[i] Default IPv4 gateway:
   * Pinging
[✓] Gateway responded.

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] highflym.com is via localhost (
[✗] Failed to resolve highflym.com via Pi-hole (
[✓] doubleclick.com is via a remote, public DNS server (

*** [ DIAGNOSING ]: Setup variables

From the DHCP-discover command in your debug log, it appears you may have two active interfaces on the Pi.

   DHCP packets received on interface lo: 0
   DHCP packets received on interface eth0: 1
   DHCP packets received on interface wlan0: 1

Run pihole -r and select the reconfigure option to reconfigure Pi-hole to the active interface and IP.

Edit file /etc/dhcpcd.conf and change the nameserver for the active interface in that file. This is the file that populates /etc/resolv.conf on reboot.

pihole -r worked like a charm after temporarily changing the nameserver! Didn't even have to edit the /etc/dhcpcd.conf afterward because started working again. Thanks a bunch for your help!

I do have one small problem remaining: it looks like my conditional forwarding isn't working anymore. It used to correctly name the clients, but now they're all named after my router (or localhost for Homebridge stuff).

I tried to update the settings to match the new DHCP server, but it hasn't helped.

I ran another debug, but I couldn't find the error: https://tricorder.pi-hole.net/1b6gfqhtre

I've also noticed that my network devices are now listing my router as their DNS server ( instead of my Raspberry Pi's IP address like they used to, even though the PiHole is the only listed DNS in my router settings. The AT&T modem still has its DNS server running, but every time I disable it I am unable to connect to the modem anymore and have to factory reset it. Maybe that's related somehow.

Just replying to say that I (sorta) fixed this by going directly to the Amplifi's internal settings menu (via the router's local IP address in browser, not the Amplifi app). I enabled "Bypass DNS cache" in the router settings, and then enabled the DHCP server on the Pi-hole itself. Pi-hole is now correctly classifying traffic in the event log, and I've got the side benefit of also use the local DNS to create custom domains locally for my other devices.

I'm still having the original problem every time I restart though, but I've made a new topic to ask specifically about it because I'm not sure if it's too different to continue asking about in this thread.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.