Getting lighthttpd placeholder page instead of new unblock page

This is on an ubuntu 16.04 that I had to purge apache from previously.

A quick fix for you could be to go to

and change this to

	$showPage = false;

where is this file? Will this possibly make the proper page come up or disable it?

It'll do what you have asked for in the title of this post:

Getting lighthttpd placeholder page instead of new unblock page

i.e. you will get an empty page.

Look at /var/www/html/pihole/

I guess I am trying to get the proper unblock page to display. I am not getting it now, I just get the lighthttpd placeholder instead.

Aha, so I misunderstood that.

Is your /var/www/html/pihole/index.php identical to the one I posted above?

There is alot more in there, but the portion you posted looks the same.

Okay, does your /etc/lighttpd/lighttpd.conf has this line?

yes. that line is there.

so what happens if you open Just a blank page (completely empty) or is there some code coming up (try to access the page source).

I get a page like this (not exact as I offsite at the moment). I have to be away from the computer for a couple of hours here, will check back in as soon as I can.

Verify that your lighttpd.conf is completely identical to

I pasted that in and still get the lighthttpd placeholder page. Rebooted pihole and still get it as well.

Then there has to be another config file in that directory which sets this page.

Compare with my result:

ls /etc/lighttpd/*

05-auth.conf         10-evasive.conf  10-flv-streaming.conf  10-simple-vhost.conf  10-userdir.conf      90-debian-doc.conf
10-accesslog.conf    10-evhost.conf   10-no-www.conf         10-ssi.conf           10-usertrack.conf    README
10-cgi.conf          10-expire.conf   10-proxy.conf          10-ssl.conf           11-extforward.conf
10-dir-listing.conf  10-fastcgi.conf  10-rrdtool.conf        10-status.conf        15-fastcgi-php.conf

10-fastcgi.conf  15-fastcgi-php.conf

You can ignore the /etc/lighttpd/conf-available folder contents.

andy@ubuntu1:~$ ls /etc/lighttpd/*
/etc/lighttpd/lighttpd.conf      /etc/lighttpd/lighttpd.conf.dpkg-dist
/etc/lighttpd/lighttpd.conf.atr  /etc/lighttpd/lighttpd.conf.orig

05-auth.conf         10-evhost.conf         10-proxy.conf         10-status.conf       90-debian-doc.conf
10-accesslog.conf    10-expire.conf         10-rrdtool.conf       10-userdir.conf      README
10-cgi.conf          10-fastcgi.conf        10-simple-vhost.conf  10-usertrack.conf
10-dir-listing.conf  10-flv-streaming.conf  10-ssi.conf           11-extforward.conf
10-evasive.conf      10-no-www.conf         10-ssl.conf           15-fastcgi-php.conf

10-fastcgi.conf  15-fastcgi-php.conf

Try removing those three files:

  • /etc/lighttpd/lighttpd.conf.dpkg-dist
  • /etc/lighttpd/lighttpd.conf.atr
  • /etc/lighttpd/lighttpd.conf.orig

and restarting lighttpd afterwards

Still just getting the placeholder.

Go to /var/www/html/ and remove all files except the two folders

ls /var/www/html/
admin  pihole
1 Like

Winner! That did it. There was an
index.lighthttpd.html in there

Glad it works now for you!