Gargoyle, Pi-Hole, and Method 2 of setup


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Method 2: How do I configure my devices to use Pi-hole as their DNS server?

Adding dhcp-option=6,PiHoleIP to my /etc/dnsmasq.config should work and allow me to use my Gargoyle DHCP and also see individual clients on my PiHole dashboard

Actual Behaviour:

It only works for a few clients. I released/renewed the lease on my laptop and iPhone to it out and I was getting ads on both and they do not show up on the client list. In fact only 6 clients show: localhost, my computer, two windows virtual machines hosted in another room, my plex server, and the pi-home (raspberrypi).

When I tried the first method of just setting the DNS IP directly to the PiHole it worked great and was filtering everything but I only saw my router in the client section.

I guess my question is am I setting something up wrong? I just bought this device today and there is possibly a setting I am overlooking? When I do method 2 am I supposed to keep the IP pointed at my PiHole? The directions only say to do the dnsmasq configuration and don’t mention needing to change the IP as well.

Debug Token:

https://tricorder.pi-hole.net/sw28ur3wbg!


#2

I am confused if you are trying to use the pi-hole not only as your DNS but also you DHCP server. If you have configured the pi-hole as both this is a sign that you have multiple DHCP servers on your network and one is configured to use a different DNS server.

Check your router and turn off DHCP serving if possible. If not possible then in the DHCP server setting on your router can you change the DNS server being handed out to the IP address of your pi-hole. If the router configuration page has room for multiple DNS servers leave the other server address blank.


#3

DHCP on the Pi-Hole is not enabled.


#4

Looking at the Gargoyle documentation there doesn’t seem to be a way to set the DNS server being handed out by the router via the GUI:

https://www.gargoyle-router.com/wiki/doku.php?id=dhcp

Also on their configuration description:

DNS Servers

These controls are slightly different depending on whether you have a router running the newer Gargoyle 1.5.X+ series of releases, or the older versions. However, in both cases, Gargoyle will, by default, serve DNS requests from your default ISP DNS servers.

In older Gargoyle releases you can enter the IP addresses of your preferred DNS servers if you do not widh to use ISP servers.

In newer Gargoyle releases, in addition to specifying custom DNS servers individually, you can specify that you want to use either the Google DNS servers, or those provided by OpenDNS.com from a dropdown box. This means that if you wish to use one of these alternate servers you will not need to enter the IP addresses manually. If you use the OpenDNS filtering service you should select the OpenDNS servers from this dropdown, and then configure your account in the Dynamic DNS section so that it gets updated properly. On newer releases that will allow the resolution of specialized top-level domains. While most people will not need this feature, leaving this checked does not inhibit performance, and will permit access to websites you otherwise would not be able to resolve.

I would try to set the “custom” DNS service to your pi-hole and see if that works.

As you stated you added a command to the configuration of it’s DNSmasq.conf file but that didn’t work and usually that is an issue because when the router reboots it builds the dnsmasq.conf file each time and the setting you added is lost. On their documentation site I didn’t see any screens for 'advanced" DHCP configuration which is where it would have been in say dd-wrt and tomato variants of router firmware.

If this doesn’t work you will have to go back to the configuration that worked and set the pi-hole address directly. You will only see the router on the list of devices due its being the device that is doing to lookup since your DHCP server in the router is sending out the routers DNS server address.


#5

My Gargoyle router is my DHCP server, I am not setting that up in Pi-Hole at all.


#6

You might try using the Pi-Hole as DHCP server.


#7

I’ve used the dnsmasq.conf for some other settings and it works fine. I double checked and the values were still inputted in the file.

I think I solved the wifi issue, my Gargoyle router has wifi disabled and I use my Synology 2600AC as an access point (no DHCP). However, for whatever reason the DNS to access the router was set incorrectly. I just deleted the field and it seems to be pulling the correct DNS now .

So now ads seem to be blocking on my phone again.

One thing I noticed was when I use method 2 (dhcp option 6) is that I am not getting that many requests at all when compared to method 1.
Blocking stats for Method 1:

  • ~1000 queries per minute
  • Percent blocked <0.5%

Blocking stats for Method 2:

  • <1000 per HOUR
  • Percent blocked >15.0%

What’s the reason for the differences?


#8

You would need to look in the query log and see what domains are being requested. 1000 queries per minute is a lot and might be due to circular traffic between the Pi-Hole and router.