FritzBox mit zwei DNS Servern im Heimnetzwerk

fritzbox

#1

Hallo, bei mir läuft Pi-hole mit Unbound auf einem Server. Funktioniert soweit auch alles.
Jetzt möchte ich als Backup für den ersten Server einen zweiten Server mit Pi-hole und Unbound einsetzen. Hier stoße ich auf das Problem, dass anscheinend die DNS Anfragen von den Clients nicht an den zweiten Server geschickt werden, wenn der erste Server offline ist.

Auf der FritzBox ist unter Heimnetz/IPv4-Adressen der erste Server als Lokaler DNS Server eingetragen. Leider besteht nicht die Möglichkeit, hier keinen Server einzutragen.

Hat jemand eine Idee, wie ich die FritzBox mit zwei lokalen DNS-Servern betreiben kann?


#2

In dem das du evtl unter Heimnetzwerk ip 4
Die Standard ip lässt zB 192.168.178.1

Unter Internet Zugangsdaten DNS Server
Dns server 1
Dns server 2

So sollte jeder pc beim Router Anfragen
Und der sendet die Fragen weiter an die beide pihole server
Und die benutzen wiederum die hinterlegten DNS Server ip in den Settings vom pi

Wäre jetzt meine idee


#3

Vielen Dank für die Antwort.
Meinst du mit Standard-IP die IP der FritzBox?


#4

Schau in dem bild den unteren Bereich Standard locales dns server

Da ist normaler weise die ip von der Fb drin
Gateway zB Standard ist da immer 192.168.178,1

Bei dir weis ich nicht ob du von deinem ip Bereich abgeweicht bist.

Da lässt du die Standard drin und denk dran deine gräde neu zu booten sonst haben die alle die alte dns


#5

Und hier sollst du deine zwei pi ips eintragen
( die pi’s müssen feste ip’s in der fb haben kein dhcp fü die pi ) image


#6

Das bitte auch hinterlegen!

Und das wäre so eine Option für dns einstellungen kannst auch andere nehmen.

Und den rest kannst auch entscheiden wie du willst

Aktivieren diese Funktion
Ganz unten muss die Fb IP wieder drin sein.
Gateway Ip
Und en name fritz.box

Neustart nicht vergessen!!

Denk dran es kann dauern bis alles hochgefahren ist. Und starte alle Geräte neu das sie alle die neue dns bekommen.

Und es ist nur eine Idee ich hoffe es hilft.

Evtl hilft dir das auch


#7

Vielen Dank. Das hat funktioniert. Einziger Nachteil: die Clients werden im Dashboard nicht mehr angezeigt.


#8

das kann nicht sein … darum musst die Funktion aktiviert werden use conditional forwarding … in beide pi und in der FB DNS Rebind Schutz - pi.hole eintragen

siehe oben alle Bilder


#9

Ich denke ich habe alle EInstellungen so (außer denen, die wegen Unbound anders sein müssen). Im Moment sind noch nicht alle Geräte neu gestartet. Ich werde mal sehen, ob die Clients wieder angezeigt werden, wenn die beiden Server und die FB neu gestartet sind.


#10

Nö, alles neu gestartet, aber Pi-hole zeigt nur noch gateway und fritz.box als clients an. Macht ja eigentlich auch Sinn, wenn die fritz.box der DNS Server für die Clients ist und dann fritz.box bei pi-hole die Anfrage stellt, die dann pi-hole an die root-server weiterleitet.