FritzBox 7580 und piHole

Ich meine das Pihole mit Buster jetzt läuft weil es ein Patch von Pihole gibt. 4.3.1

und wie updatet man pihole?

Pihole -up

also sudo apt-get Pihole -up

sorry bin nicht so vertraut damit

Also ich bin mit ssh auf die Raspberry Console gegangen und hab dann Pihole -up eingegeben, dann wurde das Update gemacht.

okay probier ich gleich mal danke

naja da man von buster der zeit kein update upgrade machen knn kann man pihole auch nicht installieren

Versteh ich nicht was du meinst.

Ich habe Raspian buster lite installiert.
Dann habe ich pihole installiert
Dann mit ssh in der Console das Update gemacht.

Läuft alles auch die Weboberfläche von Pihole.

seit heute kann ich kein sudo apt-get update mehr machen mit buster, gestern ging es noch mit strech geht es. wann hast du das denn gemacht?

Ich hab mir den Raspberry vor etwa 1 Woche gekauft und da alles gemacht, seitdem läuft es.

Ansonsten ich hab da auch nicht so viel Ahnung und kann da auch nicht mehr zu sagen.

ja jetzt geht es gerade nicht denk mal wegen den Problemen mit buster

Wenn es da inzwischen einen Patch gab nehme ich natürlich alles zurück und behaupte das Gegenteil.
Ich habe aber den Eindruck das denjo nicht ganz verstanden hat, das PiHole nicht über apt-get aktualisiert wird.
Denjo, du musst nur “sudo pihole -up” eingeben! PiHole hat eine eigene Updatefunktion!
Ich galube es reicht sogar nur “pihole -up” das sudo Passwort fragt er trotzdem ab und läuft mit root Rechten.

doch das habe ich verstanden. also mit buster gibt es wohl seitens Raspbian ja Probleme, und deswegen kann man kein update von Raspbian buster machen. es kommt eine error www… bla bla. so und deswegen kann man kein pihole installieren. wenn ihr es selber sehen wollt versucht doch einfach mal euer Raspbian upzudaten. mit Raspbian strech klappt alles ohne Probleme.

Jetzt steh ich auf dem schlauch.
DU kannst nicht über: curl -sSL https://install.pi-hole.net | bash
PiHole installieren?

richtig bei buster geht das nicht, genau so wenig wie ein update von Raspbian also apt-get update und upgrade

und da man kein Raspbian update machen kann, bekommt er keine aktuelle Pakete und dann kein pi hole

Ok, gut zu wissen.
Arbeite mit Armbian auf nem OrangePi und wollte jetzt eigentlich mal die Debian-Buster Variante testen. Mit der Ubuntu-Variante von Armbian muss ich nach einem PiHole-Update auch jedes mal erst Hand anlegen, um die Weboberfläche zum laufen zu kriegen. Da warte ich lieber erst noch ab.

ja kann ja in min std tagen wie auch immer wieder erledigt sein

mal so eine andere frage, was kann pihole alles. bis jetzt weiß ich nur das es die Werbung blockt. hab aber auch was davon gehört das es zb meine alexa´s blockt das man da nicht mehr so aus spioniert werden kann usw?

Da du ja das DHCP über die Fritzbox laufen lässt, solltest du den DNS Server auch bei DHCP eintagen.

Bei: Fritzbox -> Internet -> Zugansdaten ->DNS-Server: Den DNS Server welchen du nehmen willst, bzw welcher für draußen ist. Also zum Auflösen deiner DNS Anfragen. (Google, usw…)

Bei: Fritzbox -> Heimnetz -> Netzwerk -> Netzwerkeinstellungen -> IP-V4-Adressen -> Lokaler DNS-Server: Da die IP deines Raspberry rein.

Dann im Pihole Webinterface unter “settings” -> “DNS” die Upstream DNS Servers alle deaktivieren, bei: Upstream DNS Servers

Custom 1 (IPv4)
Deine Ip deiner Fritzbox

Und dann unten unter: Advanced DNS settings:
IP of your router (die Ip deiner Fritzbox)
Local domain name (fritz.box)

So sollte es aussehen wenn man es richtig macht.

Gruß Klaus

PS: diese liste kann ich dir ans herz legen… habe sie komplett so drin. Einfach die Urls komplett kopieren (außer die kategorien) und in Settings Blocklist einfügen. https://firebog.net/
Dann noch eine Whitelist, damit dein Handy auch noch Updates macht :wink: Commonly Whitelisted Domains
Und eine Blacklist Commonly blacklisted domains

Kontroliere ob die Zeit und Datum richtig stehen.

Das geht mit date om zu kontrolieren.