Failed to resolve doubleclick.com via a remote, public DNS server (2001:4860:4860::8888)

I have the exact same problem that's described in this post:

which was closed without resolution.

I use pihole as the DNS resolver in my openvpn container, and when I use it, I see traffic going through pihole, but nslookup fails resolving any address.

Debug Token:

https://tricorder.pi-hole.net/fSfX4wh1/

Your Pi-hole is set up using eth0 as the interface. Your eth0 interface has no IPv6 addresses configured. That's why you have no IPv6 default gateway and why you cannot reach Google's IPv6 public DNS address.

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the eth0 interface:
    172.18.0.2/16

[✗] No IPv6 address(es) found on the eth0 interface.

[i] Default IPv4 gateway(s):
     172.18.0.1
   * Pinging first gateway 172.18.0.1...
[✓] Gateway responded.
[i] Default IPv6 gateway(s):

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] tracker.publico.pt is 0.0.0.0 on lo (127.0.0.1)
[✓] tracker.publico.pt is 0.0.0.0 on eth0 (172.18.0.2)
[✓] doubleclick.com is 142.251.142.206 via a remote, public DNS server (8.8.8.8)

*** [ DIAGNOSING ]: Name resolution (IPv6) using a random blocked domain and a known ad-serving domain
[✓] aumonewcarcom.112.2o7.net is :: on lo (::1)
[✓] No IPv6 address available on eth0
[✗] Failed to resolve doubleclick.com via a remote, public DNS server (2001:4860:4860::8888)

The debug log shows that blocking is taking place and that you can reach the Internet via your router using IPv4. Name resolution in the host itself is done via your Docker engine, and any issues there are outside of Pi-hole.

Just a note:

This is harmless. Your Pi-hole is working as expected.
As chrislph explained, the resolution via IPv4 is working.

Also, IPv6 support in docker is usually disabled by default and you need to enabled it, but it's not necessary. Pi-hole (just like any other DNS server) is able to retrieve AAAA records via IPv4.