Eth0 no longer default name with Raspbian Stretch (Debian version 9)


#1

I’ve just installed raspian stretch lite (image 2017-08-16 here) and found the ethernet adapter name is now base on the Mac address, no longer eth0 by default.

Since /etc/dnsmasq.d/01-pihole.conf references eth0 as the interface, following changes are required, reference here:

sudo nano /lib/udev/rules.d/73-usb-net-by-mac.rules

You should find a line that reads:
IMPORT{builtin}="net_id", NAME="$env{ID_NET_NAME_MAC}"

Replace this line with:
IMPORT{builtin}="net_id", NAME="eth0"

To prevent any future updates from overwriting this change:
sudo cp /lib/udev/rules.d/73-usb-net-by-mac.rules /etc/udev/rules.d/

Reboot to activate the change.


No address range available for DHCPv6 request via eth0
Ubuntu after restart: DNS Service not started
#2

why did they mess whit that?


#3

explained here (Predictable Network Interface Names)


#4

Yeah this “Predictable Network Interface Names” is just bullocks.
I can predict ethX but not the MAC based names.
Always need to look them up and typing them over is just dreadfull when you dont have network/SSH (prone to make mistakes).


#5

I just hit this myself. Your description how to fix was the simplest I could find after looking in a number of places. And it worked.

Thanks for the tip!


#6

This feature has been disabled in the september 2017 release of raspbian (release notes).