Emergency: pihole dns service

Pihole dns service is not running and the docker container says unhealthy

My family as very inpatient that why I put emergency

We need more to go on, there could be a number of reasons the container is unhealthy.

It could be a port conflict, specially port 53.

Have you got the container logs?

from what I can work out gravity.db and pihole-FTL.db got integrity errors
I renamed to .bak and fixed the issue for now, but is there a way to recover the old db

If I hadn't temporary fixed this we would have had no DNS for 24 hours now

can I fix the old databases or would I be best restoring from a backup

I will just restore from a backup, because nobody actually seems to care that we have no blocking or statistics

In the future, if you have issues you should follow the help template (you're prompted for this when you create a new topic under the category "Help"). At the very least, you should provide a Debug token, without which the Devs don't have the information they need to provide helpful guidance. They need something to go on beyond the information given in the original post. Also, it may be a Docker issue and not really rooted in Pihole, no way to know based on what is given.

They are volunteer, but quite resourceful.

I don’t find the help template suitable for what I want to say, so I don’t use it

I gave information from a debug token, nobody asked for the full thing

I clearly said the databases have integrity errors

Trying to restore from a backup, but my backup server is really slow

I have a problem I deleted the database as I redirected /etc/pihole in the container

And it turns out I was not backing up the location

Actually, this request is on the template.

I understand not every part of the template structure is suitable for your specific case, but next time add the debug token anyway.
If the debug log has something useful, we will be able to help you faster.
If it has no useful information, it won't hurt.

1 Like

Like I said I don't like the template as it does not give me the chance to provide additional information
and its structure is not how I would ever right, its confusing to me

and setting to help docker does not give you the template

the expected behavior is always "it should work"

is everything running right, it did notice other issues in my debug token
it failed to connect to a test domain
the IPv6 is nothing to worry about though IPv6 is disabled on this network
still got integrity errors on pihole-FTL.db as well

As you said, IPv6 is not an issue (specially inside docker).

It only failed to connect using an IPv6 address. This is expected. Not an issue.

If you don't care about the previous data, you can stop the container, delete the database file and restart the container. A new empty database will be created.
(The steps above are easily done if you are using a bind mount to store Pi-hole files, but you actually never posted your compose file, so I don't know if you are using a bind mount, a different kind of volume, or no volume at all.)

If you care about previous data in the database you could try to manually fix the issue by:

  1. exporting the data and then importing it into a new database or
  2. executing a recovery.

But in both cases there are limitations and no guarantee the data will be fully recovered.

This is an old backup of the database it should not have integrity errors, can they be fixed or do I need a new database

Because I don't use a compose file, only docker run
/etc/pihole is mounted at /docker/pi-hole/etc/pihole on the host

I started again but the database is not saving any data

its saving data now

would it be possible to copy client group configuration and the group from the old database
and none of the domains are there so gravity.db is not working either

my backup databases are clearly corrupt as well, there no data in them just what is already set

I have I can find a gravity.db in my backups that is useable

why did I delete the databases that originally had the errors
I could have tried to recover the data from them

Current Issues:
Hostnames are not fetched from conditional forwarding
gravity.db only contains what ships with pi-hole and is read only
Domains are missing but are storing in gravity.db so they will be
same for clients and groups

for an older teleporter file but it will not restore

Start importing...
Failed to prepare statement for adlist table.INSERT OR IGNORE INTO adlist (id,address,enabled,date_added,comment) VALUES (:id,:address,:enabled,:date_added,:comment);Processed adlist (0 entries)
Failed to prepare statement for adlist_by_group table.INSERT OR IGNORE INTO adlist_by_group (adlist_id,group_id) VALUES (:adlist_id,:group_id);Processed adlist group assignments (0 entries)
Failed to prepare statement for blacklist table.INSERT OR IGNORE INTO domainlist (id,domain,enabled,date_added,comment,type) VALUES (:id,:domain,:enabled,:date_added,:comment,1);Processed blacklist (exact) (0 entries)
Failed to prepare statement for regex_blacklist table.INSERT OR IGNORE INTO domainlist (id,domain,enabled,date_added,comment,type) VALUES (:id,:domain,:enabled,:date_added,:comment,3);Processed blacklist (regex) (0 entries)
Failed to prepare statement for client table.INSERT OR IGNORE INTO client (id,ip,date_added,comment) VALUES (:id,:ip,:date_added,:comment);Processed client (0 entries)
Failed to prepare statement for client_by_group table.INSERT OR IGNORE INTO client_by_group (client_id,group_id) VALUES (:client_id,:group_id);Processed client group assignments (0 entries)
Processed local DNS records (0 entries)
Failed to prepare statement for domain_audit table.INSERT OR IGNORE INTO domain_audit (id,domain,date_added) VALUES (:id,:domain,:date_added);Processed domain_audit (0 entries)
Failed to prepare statement for domainlist_by_group table.INSERT OR IGNORE INTO domainlist_by_group (domainlist_id,group_id) VALUES (:domainlist_id,:group_id);Processed black-/whitelist group assignments (0 entries)
Failed to prepare statement for group table.INSERT OR IGNORE INTO "group" (id,name,date_added,description) VALUES (:id,:name,:date_added,:description);Processed group (0 entries)
Failed to prepare statement for whitelist table.INSERT OR IGNORE INTO domainlist (id,domain,enabled,date_added,comment,type) VALUES (:id,:domain,:enabled,:date_added,:comment,0);Processed whitelist (exact) (0 entries)
Failed to prepare statement for regex_whitelist table.INSERT OR IGNORE INTO domainlist (id,domain,enabled,date_added,comment,type) VALUES (:id,:domain,:enabled,:date_added,:comment,2);Processed whitelist (regex) (0 entries)
Done importing

add adlists return no such table after deleting the database

has the adlist syntax changed as I got some adlists that I used before and most of domains are invalid

I was using incorrect links

hostnames are still not working

and now I have my apple watch issue back

Can someone give my some advice, I am setting up from nothing

Sorry for all the posts, I hate being ignored
I think I get pi-hole 99% working but there are still some devices not getting the hostname from the DHCP server

Also if I go to the network table and click on a client no queries are found, but if I do it from top lists it finds them

Anybody? Please can you help me sort out these final issues

Why do I always get ignored, is it because I send too much information over many posts and want a reply within a few days

It’s the same on every discourse and forum
Everybody ignores and hates me

have I got to create yet another new post
why do I get ignored everywhere, everybody ignores and hates me
I think I have ADHD, Please can somebody answer me before I lose interest and this won't be sorted until next year
I am very inpatient