DNSStubListener setting on lubuntu 18.04

I'm essentially experiencing the same behavior detailed in this topic: Dnsmasq not starting - Ubuntu 18.04

I was not able to install pi-hole until editing /etc/systemd/resolved.conf and setting "DNSStubListener=no"

After restarting systemd-resolved, I was able to install pi-hole.

Unfortunately, this results in the consequence of being unable to resolve local IP addresses (I'm using dnsmasq on my router running dd-wrt, which resolves local clients to 'hostname.lan'), so all clients appear in the Pi-hole Admin Console by IP address.

If I stop pihole-FTL, set DNSStubListener=yes, restart systemd-resolved, and then start pinhole-FTL, I can actually see the resolved local hostnames show up in the Admin Console. However, pi-hole will not filter in this state due to dnsmasq-base running on port 53.

Is there some way I can get pi-hole running while still being able to resolve local hostnames?

Debug Token:


you will need to disable dnsmasq in your router for more than just the router ip to appear

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.