Dnsmasq fails on Pi-hole 3.3

v3-3
#19

i’m also have problem here…fresh install on raspberrypi.DNSMasq unable to start on option

   log-queries=extra

for working it need to be commented…

0 Likes

#20

hi…

fresh install from raspberry pi pihole + dnscrypt…still using default config.seem everything running good but no queries appear on dashboard

[✓] Your debug token is: ht9o13lk29

i have test that my network DNS pointed to raspberry pi IP addr and when i’m test using dnsleak all resolver are correct

need an enlightment here…thank you…

0 Likes

#21

According to your debug log, you’re on Jessie, did you try the fix as marked by solution in this thread?

0 Likes

#22

I also tried reverting to an earlier version, but I get this error:

root@localhost:/etc/.pihole# sudo git checkout v3.2.1
error: pathspec ‘v3.2.1’ did not match any file(s) known to git.
root@localhost:/etc/.pihole#

0 Likes

#23

Hi

i’m try to use git as follow but got err here

root@retropie:/etc/.pihole# git checkout v3.2.1

error: pathspec ‘v3.2.1’ did not match any file(s) known to git.

0 Likes

#24

OK so updated and seemed working but then saw this freakout with Jesse. I’m also running Jesse so I quickly ran the commands to get the prior versions but now looking I have dnsmasq 2.76 installed and I think it likely would have worked yet now I am stuck on this head portion.

How can I GET OUT of this error which seems to have affected this one use with VPS who didn’t have dnsmasq v2.73 or higher for the additional logging? Does this affect everyone with Jesse or just specific cases? sigh

I should have read more into it before downgrading but since it was at the very top of the release page; I jumped the gun too quick. Anyway now to get back to the full 3.3 release as it should be? Thanks!

From the triage log:
*** [ DIAGNOSING ]: Core version
[i] Core: v3.2.1 (How do I update Pi-hole?)
[i] Branch: HEAD (The pihole Command With Examples)
[i] Commit: v3.2.1-0-ge602008

*** [ DIAGNOSING ]: Web version
[i] Web: v3.2.1 (How do I update Pi-hole?)
[i] Branch: HEAD (The pihole Command With Examples)
[i] Commit: v3.2.1-0-g31dddd8

*** [ DIAGNOSING ]: FTL version
[✓] FTL: v2.13.2 (How do I update Pi-hole?)

*** [ DIAGNOSING ]: dnsmasq version
[i] 2.76

*** [ DIAGNOSING ]: lighttpd version
[i] 1.4.35

*** [ DIAGNOSING ]: php version
[i] 5.6.30

*** [ DIAGNOSING ]: Operating system
[✓] Raspbian GNU/Linux 8 (jessie)

Should I just ‘git checkout’ to remove the head commit in place? Thanks!

0 Likes

#25

Think I figured it out by resetting the HEAD back to master and then doing a ‘pihole -r’ then ‘pihole -up’. Seems it’s back to v3.3/v3.0(FTL)

0 Likes

#26

Still not fixed
When trying to revert to old version I get the error: pathspec ‘…’ did not match any file(s) known to git

(Using Synology DS412+)

0 Likes

#27

The fix worked for me after trying again about 15 minutes ago.

0 Likes

#28

Yeah, something odd on my build but going back a few builds of Jesse and Pi-Hole so downloaded the new Stretch image of Rasbian and going to start over anew. Probably a good thing for me. Good Luck!

0 Likes

#29

This is my Token @DanSchaper 0m62ng6e20

Odroid C1 With DietPi .(clean install DietPi, clean pi-hole)
Previous version(s) did work without any issues on Debian Jessie mini for Odroid C1, but after the problem i started clean with Debian Jessie, still this issues, after that clean install DietPi, same issues.

0 Likes

#30

We’re working on a better fix right now, we’ll update when we have that pushed out for general use. This should solve the Jessie issue when it is done.

4 Likes

#31

I had the same issue with the ‘sudo git checkout v3.2.1’ as others.

As a temporary workaround I was able to do a ‘pihole -r’, reconfigure, and disable query logging.
But this obviously makes the admin page useless.

I would love to upgrade to stretch, but unfortunately retro-pie does not support it, and I have my pi doing both at the moment. I tried messing around with apt-policies to see if I could only upgrade dnsmasq, but there ended up being a rats-nest of dependencies .

0 Likes

#32

Ah, I’m still fuzzy with git. You need to do a ‘git fetch --tags’ and then execute ‘git checkout v3.2.1’

0 Likes

Pi ubuntu no dns
#33

I don’t want to send people down the wrong path, but I got mine working by moving my firewall to iptables. Might just be a coincidence, but I am running Jesse with no issues.pi@RasPiHole:~ $ sudo systemctl status dnsmasq
● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2018-02-16 11:07:02 CET; 11h ago
Process: 661 ExecStartPost=/etc/init.d/dnsmasq systemd-start-resolvconf (code=exited, status=0/SUCCESS)
Process: 621 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status=0/SUCCESS)
Process: 597 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCCESS)
Main PID: 654 (dnsmasq)
CGroup: /system.slice/dnsmasq.service
└─654 /usr/sbin/dnsmasq -x /run/dnsmasq/dnsmasq.pid -u dnsmasq -r /run/dnsmasq/resolv.conf -7 /etc/dnsmasq.d,.dpkg-dist,.dpkg-old,.dpkg-new --local-service --trust-anchor=.,19036,8,2,49aac1

Feb 16 11:07:01 RasPiHole systemd[1]: Starting dnsmasq - A lightweight DHCP and caching DNS server…
Feb 16 11:07:01 RasPiHole dnsmasq[597]: dnsmasq: Syntaxprüfung OK.
Feb 16 11:07:02 RasPiHole systemd[1]: Started dnsmasq - A lightweight DHCP and caching DNS server.

My rules for v.4 are…

Generated by iptables-save v1.6.0 on Thu Feb 15 21:24:58 2018

*filter
:INPUT ACCEPT [309:86582]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [697:161045]
-A INPUT -i lo -p tcp -m tcp --dport 4711:4720 -j ACCEPT
-A INPUT -p udp -m udp --dport 53 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 53 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 80 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 22 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 443 -j REJECT --reject-with tcp-reset
-A INPUT -p udp -m udp --dport 80 -j REJECT --reject-with icmp-port-unreachable
-A INPUT -p udp -m udp --dport 443 -j REJECT --reject-with icmp-port-unreachable
COMMIT

Completed on Thu Feb 15 21:24:58 2018

in case you want a closer look: [✓] Your debug token is: nml4nuwchj

0 Likes

#34

How do you revert back to the main branch?

0 Likes

#35
cd /etc/.pihole
sudo git checkout master
pihole -r
0 Likes

#36

Now when I try to revert to the previous version when running the first git command:
error: pathspec ‘v3.2.1’ did not match any file(s) known to git.

1 Like

#37

Try pihole checkout master to pull all the tags and branches and then if it’s still not on master do the sudo git checkout master again.

0 Likes

#39

sudo git checkout tags/v3.2.1 is the proper command to check out the tagged commit for v3.2.1

0 Likes