Dnsmasq fails on Pi-hole 3.3

Debian Jessie should have version 2.73 of dnsmasq, have you updated the OS and installed the latest packages? We need 2.73 for the extra logging facility.

Edit, sorry looks like it's 2.72-3 and not 2.73.

Everything is up to date and looking at the Debian jessie repo 2.72 is the latest.

apt-cache policy dnsmasq
  Installed: 2.72-3+deb8u2
  Candidate: 2.72-3+deb8u2
  Version table:
 *** 2.72-3+deb8u2 0
        500 http://deb.debian.org/debian/ jessie/main amd64 Packages
        500 http://security.debian.org/debian-security/ jessie/updates/main amd64 Packages
        100 /var/lib/dpkg/status

I updated my post to reflect that, is it possible to update to Stretch from Jessie on your install?

No my VPS host does not support Stretch yet.

How can I roll back as pihole checkout core doesn't allow me to go back to 3.2.1.

We're working on getting a solution for people that are locked in to Jessie and can't update. It should allow you to roll back to a previous version.

Can you give the below a go and see if that reverts you to a working version?

cd /etc/.pihole
sudo git checkout v3.2.1
cd /var/www/html/admin
sudo git checkout v3.2.1
pihole -r
pihole checkout ftl v2.13.2

That has worked. Dnsmasq is now starting without any errors and I can now do a dnslookup.

Good to hear, we should have a better solution coming up in a bit but for now just hold off on upgrading as we need a more current version of dnsmasq.

k, happy to help if you need anything.

1 Like

Unfortunately this has not resolved this issue for me but I'll give it another go after I've had some sleep.

Not working :frowning:

  • issue after revert complete web is slower and shows totaly data :-((

after updating, the system is somewhat slowed down and, in addition, poorly displays statistics.

I had previously set from 00:00 to 23:59 - 1 day and now it started running in 24 hours :frowning:

i'm also have problem here...fresh install on raspberrypi.DNSMasq unable to start on option


for working it need to be commented...


fresh install from raspberry pi pihole + dnscrypt..still using default config.seem everything running good but no queries appear on dashboard

[✓] Your debug token is: ht9o13lk29

i have test that my network DNS pointed to raspberry pi IP addr and when i'm test using dnsleak all resolver are correct

need an enlightment here...thank you...

According to your debug log, you're on Jessie, did you try the fix as marked by solution in this thread?

I also tried reverting to an earlier version, but I get this error:

root@localhost:/etc/.pihole# sudo git checkout v3.2.1
error: pathspec 'v3.2.1' did not match any file(s) known to git.


i'm try to use git as follow but got err here

root@retropie:/etc/.pihole# git checkout v3.2.1

error: pathspec 'v3.2.1' did not match any file(s) known to git.

OK so updated and seemed working but then saw this freakout with Jesse. I'm also running Jesse so I quickly ran the commands to get the prior versions but now looking I have dnsmasq 2.76 installed and I think it likely would have worked yet now I am stuck on this head portion.

How can I GET OUT of this error which seems to have affected this one use with VPS who didn't have dnsmasq v2.73 or higher for the additional logging? Does this affect everyone with Jesse or just specific cases? sigh

I should have read more into it before downgrading but since it was at the very top of the release page; I jumped the gun too quick. Anyway now to get back to the full 3.3 release as it should be? Thanks!

From the triage log:
*** [ DIAGNOSING ]: Core version
[i] Core: v3.2.1 (How do I update Pi-hole?)
[i] Branch: HEAD (The pihole Command With Examples)
[i] Commit: v3.2.1-0-ge602008

*** [ DIAGNOSING ]: Web version
[i] Web: v3.2.1 (How do I update Pi-hole?)
[i] Branch: HEAD (The pihole Command With Examples)
[i] Commit: v3.2.1-0-g31dddd8

*** [ DIAGNOSING ]: FTL version
[✓] FTL: v2.13.2 (How do I update Pi-hole?)

*** [ DIAGNOSING ]: dnsmasq version
[i] 2.76

*** [ DIAGNOSING ]: lighttpd version
[i] 1.4.35

*** [ DIAGNOSING ]: php version
[i] 5.6.30

*** [ DIAGNOSING ]: Operating system
[✓] Raspbian GNU/Linux 8 (jessie)

Should I just 'git checkout' to remove the head commit in place? Thanks!

Think I figured it out by resetting the HEAD back to master and then doing a 'pihole -r' then 'pihole -up'. Seems it's back to v3.3/v3.0(FTL)

Still not fixed
When trying to revert to old version I get the error: pathspec '…' did not match any file(s) known to git

(Using Synology DS412+)

The fix worked for me after trying again about 15 minutes ago.