DHCP läuft aber verbindet nicht.

#1

Hi
Habe einen speedport weshalb mir nichts anders als der DHCP vom pi hole übrig bleibt

Der läuft auch und vergibt die richtigen adressen, aber leider lässt sich keine seite aufrufen.
Google suche funktioniert, und andere online dienste wie z.b. Whatsapp laufen ohne probleme. Normales surfen funktioniert leider garnicht. Wenn ich das pi hole deaktiviere ändert sich garnichts.

Das ganze läuft auf nem pi 3 model B
Und installiert über den einfachen ein befehl.

0 Likes

#2

Please send us the token generated by

pihole -d

or do it through the Web interface:

0 Likes

#3

bitteschön

[✓] Your debug token is: https://tricorder.pi-hole.net/hlvn0ts9tx!
1 Like

#5

ok update.
am pc funktioniert alles soweit. (nur manche ads kommen trozdem durch.)
-ein frisches raspbian aufgesetzt.

-Der raspberry ist jetzt mit kabel im netzwerk.

-DHCP vom pihole zeigt nur geräte die über ethernet verbunden sind

-Wlan geräte alle neu eingelogt

-keine veränderung der pihole DHCP leases

-surfen mit pc (eterhnet geht)

-surfen mit smartphone geht nicht (ERR_ADDRESS_UNREACHABLE)

-DHCP am router einschalten wärend pihole DHCP aktiv ist

-Surfen mit smartphone geht mit etwas weniger werbung

-im query log werden nur adressen gezeigt die ich mit dem browser aufrufe.
also alle anderen apps schleichen sich vorbei

könnte das damit zusammenhängen das der Speedport den DHCP server für ipv6 niemals ausschaltet?

0 Likes

#6

Da hier auch ein Speedport (Hybrid) läuft, meine Konfiguration ist wie folgt

Speedport:

  • DHCP aus
  • ‘Lokale IPv6-Adresse (ULA) verwenden’ an
  • Über das versteckte, aber per Tampermonkey & entspr. Script erreichbare, Engineer-Menü manuell die DNS-Server (IPv4/IPv6 vom Raspi/Pi-hole) angegeben
    screenshot

Pi-hole:

  • DHCP an

Auf dem Smartphone trotz der o.g. Konfiguration vorsichtshalber die DNS-IPv4 vom Raspi/Pi-hole bei der WLAN-Verbindung eingetragen. Auf dem PC lasse ich die DNS-IPs per DHCP beziehen, habe sie also nicht manuell angegeben

0 Likes

#7

ok Tampermonkey läuft
script läuft auch
aber wie komme ich in das menü?

Speedport W 925V

0 Likes

#8

Im Script muss in der gelben Zeile (siehe Pastebin) die korrekte und vollständige IP des Speedport eingetragen sein. Meldet man sich dann im Webinterface des Routers an, sieht man oben rechts das Menü

21

Dann im Engineer-Menü in den Bereich DNS wechseln

24

0 Likes

#9

Jap hab ich
Nur ist das script für einen anderen speedport.

bei meiner version befindet sich das engeneer menü hinter volgender adresse
http://speedport.ip/engineer/html/version.html

nur leider lassen sich dort keine änderungen vornehmen.

muss ich mir wohl doch ne fritzbox zulegen.

danke für die mühe

0 Likes