Devices not using Pi-hole

Hi Jfb

Thanks for your answer.
Yes, I restarted my box (used as router).
I also shutdown and restarted some devices but still « No device using Pi hole ».

I did it yesterday evening and this morning, still the same.

I can’t understand what I missed...


Post make/model of the router and screenshots of the settings you changed on the router.
Can copy/paste screenshot directly into discourse here.

Hi deHakkelaar,

I am accessing internet thru a small French Internet provider called "K-Net", using their specific box.

You can find hereafter a screen shot of the configuration screen related to LAN:

I have defined 2 static addresses : one for my Raspberry running pi-hole (192.168.1 .250) defined also as Primary and secondary DNS server + one for a local printer (

Hope it can help.


Check if your raspberry pi has internet access by SSH or Logging into it and see if you have enabled the right interface WIFI/ Ethernet to connect to internet and cross check the ip of LAN/ Ethernet.
Additionally check your router's additional settings for DNS Server Setting , i had it it misconfigured by adding Pi Hole Ip.

Hi Dilip_prasad,

Here is a screenshot of the setting of Pi-hole interface:

My raspberry is connected thru ethernet so config is OK.
All my devices are well seen also on Interface eth0:

What is maybe strange is the Pi-hole IPv4 address : Shouldn't it rather be only ?

Here is the setting of my DNS:


The IP address is being shown with it's subnet mask. The "/24" indicates that the subnet mask is This is a normal display.

From one of the clients on your network that is shown as not using Pi-hole, please run the following commands from either the client terminal or command prompt, and post the output here:

nslookup pi.hole

nslookup pi.hole

Here is the output of both commands:


That device is using Pi-hole for DNS.

It is likely that your router is configured in such a way that all the DNS traffic from individual clients is shown as originating from the router, and not from the clients.

Let's take a look at which clients are sending Pi-hole DNS requests. Please post the output of:

echo ">top-clients withzero (50) >quit" | nc localhost 4711

Hi jfb,

There is no oputput when executing this command:



Hi jfb

Did you had a chance to see my last answer ?

Did I missed something when executing the command requested ?
echo ">top-clients withzero (50) >quit" | nc localhost 4711

Thanks for your support

That is odd. There should be at least a line or two, as there should always be at least one client (localhost). Check that the quote symbol didn't get smartened - manually overwrite the quotes from your terminal.

Hi jfb,

Still no output with this command...

I made a scan of listening ports in my raspberry. Here is the result:

Are the two last lines for port 4711 correct ? (IP address)
IPV4 address for Pi hole is


Could you manually verify if the devices (client) ip settings. There could be some time cache / DNS Set to Router's IP address. Try to reset that as well just in case, hope your client does not have DNS like (Google' DNS)

Hi Dilip_prasad,

Here is the setting of my iPhone that should be using Pi Hole:

Everything should be ok for me... but my device is still seen as “Not Using Pi-hole”

For information, in the meantime I have fully rebuild my Raspberry Pi and reinstall Pi-hole. Nothing as changed....


Seems the Pi is able to capture the devices present, however the traffic is still not routed via the PI for some reason
Try this and see if it helps in any way

I hope you have disabled IPv6 routing in the Pi hole settings . If possible post the snapshot of those settings as well. I dont have rights to access your logs.

Also in the worst case, some times the router may have limited capabilities and have hardcoded DNS, try with a temporary router without internet connection should also do inorder to test the possibility. This was a pain for me initially to setup being a NOOB but once i completed it , i reaped the benefits of completing the setup.

Hi dilip_prasad,

Thanks a lot for supporting me !

Here are the results of DNS Test:

Everything seems good.

Here are some screenshots of Pi-Hole settings:

Hope you will be able to identify what I did wrong.


The end of Pi-hole settings:


Check you interface listing behaviour, its not set to "Listen only interface eth0" . I hope you have connected your raspberry pi to the router via lan cable, if so please choose "Listen only interface eth0" and connect with a lan cable. I am not sure how well pi hole will work as a DHCP over wifi - even i am facing issues making pi work over wifi. With land and "Listen only interface eth0" it should work for you.

Also try to ping or any other public dns to verify ping response after changing settings, if that does not work you may modify resolv.config temporarily to add a name sever to verify everything. Please do restart the services and settings and pi boot once done

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.