Device does not use Pi-hole

In the network overview my individual devices are showing up in red. Saying they wont use pi-hole.

The devices are all manually set to the pi-hole’s ip in the dns settings.

What am i doing wrong?

Are the clients connected to Pi-Hole? If they are, you aren’t doing anything wrong and the ARP cache hasn’t updated. Run this command from the Pi terminal to see which clients have or are connected to Pi-Hole for DNS:

echo ">top-clients withzero (50)" | nc 127.0.0.1 4711

Hi,

0 42 192.168.1.128
1 38 127.0.0.1 localhost

these two are connected. The top one is connected because i added something to the blacklist through the query log.

The other arent showing up in the log

Please send us the token generated by

pihole -d

or do it through the Web interface:

I’ve changed the DNS in the router to the ip adress of the pi-hole. Now 7 of my devices connected.

Except for my nvidia shield (android) and Windows pc.

Hi…I’ve just set up my PiHole, and I’m currently in the process of changing my devices’ DNS settings to use PiHole (can’t do network-wide blocking as family’s work computers don’t play nice with it). It’s working perfectly so far on Windows, but my Pixel XL doesn’t seem to want to use PiHole.