Dashboard update problem

The hole works fine- youtube ads get skipped, 'https://fuzzthepiguy.tech/adtest/' shows no ads.

But the dashboard seems to register none of the requests- all queries and general activity is uniform, and the 'Total' quary tally does not update either.
See screenshot.

Are queries shown in the query log, or in the dnsmasq log at /var/log/pihole.log?

What is the output of the following command from the Pi terminal:

echo ">stats >quit" | nc localhost 4711

t looks from your screen shot that no clients are using Pi-hole. The hourly activity is Pi-hole polling clients on the network.

Hi there! Indeed, the query log is populated (see photo).
The output of the command reflects the dashboard (see photo)


No clients are using Pi-hole.

From a client that you believe should be connected to the Pi-Hole for DNS, from the command prompt or terminal on that client (and not via ssh or Putty to the Pi), what is the output of

nslookup pi.hole

Server: D-link.HomeGateway

*** D-link.HomeGateway can't find pi.hole: Non-existent domain

That's odd since the router does direct DNS requests to the pi-hole's address, and adblocking does seem to be working.

This does not appear to be working. Run these commands, which will direct the query to Pi-hole:

nslookup pi.hole xxx

nslookup flurry.com xxx

where xxx is the IP of your Pi-hole. An example would be nslookup pi.hole

Are you running an adblocker on the browser? Pi-hole isn't receiving or blocking any requests, so something else is blocking ads.


*** UnKnown can't find pi.hole: Non-existent domain


I do have a browser adblocker. :man_facepalming:

My router DNS settings point to my pi-hole IP and to cloudflare. OK thanks- so at least we know I'm somehow misconfigured, and that this isn't just a strange glitch.

Pi-hole should be your only DNS server. Given multiple DNS servers, clients are free to use any of them at any time, and this can result in some DNS traffic bypassing Pi-hole.

What was the exact command you ran?

Please upload a debug log and post just the token URL that is generated after the log is uploaded by running the following command from the Pi-hole host terminal:

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

The token is https://tricorder.pi-hole.net/nb7jF7i3/

I gave up on setting it up through the router, and after changing the DNS settings locally on the host, some blockings are showing up. It does seem to work then, only not optimally for me (through the router).

They do not appear to:

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   Timeout: 10 seconds
   WARN: Could not sendto() in send_dhcp_discover() (/__w/FTL/FTL/src/dhcp-discover.c:233): Network is unreachable
   * Received 288 bytes from eth0:
     Offered IP address:
     Server IP address: N/A
     Relay-agent IP address: N/A
     BOOTP server: (empty)
     BOOTP file: (empty)
     DHCP options:
      Message type: DHCPOFFER (2)
      lease-time: 3192 ( 53m 12s )
      domain-name: "HomeGateway"
      --- end of options ---
   DHCP packets received on interface lo: 0
   DHCP packets received on interface wlan0: 0
   DHCP packets received on interface eth0: 1

You have the option of using Pi-hole as your DHCP server.

I'll give it a try. Thanks :muscle:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.