Customize DNS settings in ISP provided routers


My trial with PiHole is working great since a week (PiHole version v5.16.2 on Debian 11 stable). I would like to help some relatives to setup PiHole. However, they have different routers models. And those routers are supplied by their Internet Service providers.

In general, is it possible to configure a ISP provided router to use a custom DNS server?

For simplicity, I would prefer to configure the DNS server within the router. So that all home devices just connect to the home network as before (without any modification in their DNS settings) and benefit immediately from the PiHole service.

In my own implementation, I use my own router with DD-WRT firmware, which allows to configure DNS settings. But my relatives use ISP provided routers and I would prefer to avoid adding a custom router on top of the PiHole device.

Thanks in advance for any help.

It really depends on the router model and ISP.

There is no general "one-size-fits-all" answer to that question.

Each ISP uses a different router. Some of these routers use different firmware or a "locked down" configuration, but others allow any configuration.

I think you will need to try it, one by one.

Let's assume the ISP provided router doesn't allow to customize DNS settings. What would be the most popular workaround?

  1. Open the Admin page of the ISP provided router and disable its DHCP function. Then connect your own router to the ISP provided router.

  2. Configure EACH home device, to set the PiHole IP address as DNS server. This sound quite time consuming as there are possibly a variety of home devices (streaming boxes, Android, iOS, Windows, Linux). I wonder if this approach is a popular option.

Pihole is a DNS server. You could set up environment variables in the Pihole to use the the ISP router IP, which usually acts as a DNS server as well, as your upstream DNS.

@rdwebdesign Thanks for the link. I did start using that FAQ link you mentioned above. And I used Method1 in that FAQ. Which ... was NOT working. There is a missing info, the option "Ignore WAN DNS" option should be enabled. Got the complete and working solution from a post from the DDWRT forum: use PiHole as simple DNS-Server with DD-WRT

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.