Clients not connecting, not blocking

#1

I recently updated pihole to the latest version and ran pihole -r and “Reconfigure” and now none of my clients are using the Pihole DNS and installing falling back to the secondary DNS servers I put in my router. When I manually set the DNS server on one of the client machines to the Pihole, web address names are not resolved.

Expected Behaviour:

Clients should be using Pihole as the DNS server.

Actual Behaviour:

Instead my client devices use the secondary DNS servers I supply in the router settings (see screenshots below). Under the “Admin Console”, there is only 1 client. None of the other devices on the network go through the RPi Pihole for their DNS server.

Screenshots of Pihole Console, Router and Client Machine Configuration Settings

Output of running nslookup:

nslookup pi.hole 192.168.1.12
DNS request timed out.
    timeout was 2 seconds.
Server:  UnKnown
Address:  192.168.1.12

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out

Debug Token:

p5qdzwre0n

Additional information

-Using the router as the DHCP
-Pihole version v4.3
-Raspbian GNU/Linux 9 (stretch)

#2

In your Rpi, you need to select a valid upstream server.

Putting the IP of (what i assume is) your Pi-hole as a custom, will not work as it throws it in a loop (and that’s why it’s not working).

Just select a few/some from the right and unless you’re using unbound, disable the .12 as your custom.

If you really want to not depend of a public DNS resolver as your upstream, you can always use unbound locally and go that route.

Give this a spin:
https://docs.pi-hole.net/guides/unbound/

In order for your clients to show up, you need to specify the DNS server for each client that’s connecting to the network.

That can be done at DHCP server lever, or you can use Pi-hole as your DHCP server.

If however you end up using anything else (not managed by you, via a different Pi-hole instance) as your secondary DNS server then you will get some ads that will slip through.

Here’s why:

#4

I was setting the Customer Upstream server as per the instructions, Method 2. Don’t know if these instructions are outdated with the latest updates.

Anyways I removed the Custom Upstream server and selected to use the Cloudfare servers. I also removed the secondary DNS servers in my Router > Basic > Network > “Static DNS” fields and my clients still aren’t connecting to the Pihole after a ipconfig /renew + ipconfig /flushdns + router reboot + RPi reboot.

However and after making these changes, I cannot ping websites on both the RPi and the client machines. I can still ping using the IP addresses.

I also tried setting up according to these instructions, however when I run dig pi-hole.net @127.0.0.1 -p 5353 , I get the following:

pi@raspberrypi:~ $ dig pi-hole.net @127.0.0.1 -p 5353
; <<>> DiG 9.10.3-P4-Raspbian <<>> pi-hole.net @127.0.0.1 -p 5353
;; global options: +cmd
;; connection timed out; no servers could be reached
#5

You seem to have some really really REALLY weird settings (all over the place) in that debug log.

Several DHCP ranges everywhere and what stands out the most, and possibly the cause of your issue is this:

   server=/TomatoUSB/192.168.1.1
   server=/1.168.192.in-addr.arpa/192.168.1.1

Just use the IP 192.168.1.1 …

Can you upload another debug log after the changes?

I’d like to look at it with the latest changes …

LE. and then there’s also this:

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] interreklame.de is 0.0.0.0 via localhost (127.0.0.1)
[✗] Failed to resolve interreklame.de via Pi-hole (192.168.1.12)
#6

Updated debug token: lsp4ffinib

I unchecked “Use Conditional Forwarding” under Settings > DNS Tab > Advanced DNS settings and I noticed the server=/TomatoUSB/192.168.1.1... entries have been removed from the debug log.

I’m notice that there are 2 randomly blocked domains as well (interreklame.de, public37.bravenet.com). Part of my problem is that the only client that is recognized by the PiHole is the RPi itself. Not sure what is trying to access those domains.

#7

Everything looks good and fine at Pi-hole level with that one exception:

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] public37.bravenet.com is 0.0.0.0 via localhost (127.0.0.1)
[✗] Failed to resolve public37.bravenet.com via Pi-hole (192.168.1.12)

Then I saw this:

image

Disable those 2 options and you should be back in business :slight_smile:

#8

I unchecked those two settings and unfortunately it hasn’t fixed the issue. I restarted the router + the RPi + set the DNS server on my client machine to the RPI’s IP address. The PiHole admin console still shows only 1 client and I the DNS name server isn’t resolved on the client machine.

#9

It’s strange because Pi-hole IS working.

We can see that when trying to resolve from Pi-hole via localhost (127.0.0.1).

However, when the DNS request goes through your router and the DNS request is sent to 192.168.1.12 (routed via the router), it gets intercepted and stopped (at router level) and it never reaches the said IP.

is that 192.168.1.1 ?

#10

Strangely no, the client IP address is 127.0.0.1.
For my network, 192.168.1.1 is the IP address for the router.

Screenshot of current PiHole Admin Console

#11

That’s fine, that means that whatever ran on 127.0.0.1 (and that would be the debug process and from what i see a few time updates), actually hit Pi-hole for it’s DNS requests.

This pretty much tells us that Pi-hole is working, the DNS request routing is broken on the router (from the router to Pi).

For testing purposes, disable the DHCP server within the router and enable it within Pi-hole and try it like that.

I believe the router is playing tough to get and it’s not letting anything pass as a DNS request, past it.

#12

Trying to use the RPi as the DHCP server doesn’t work either. I don’t see any client devices showing up in the PiHole Admin console. Under Settings > DHCP Tab, no devices get a DHCP lease to the PiHole either (see Pihole Admin Console screenshot).

A couple months ago I tried getting the RPi to act as my DHCP server and I remember that I never got it to work. Back then, the problem was the client devices were not using the PiHole as the DNS server. This time the PiHole DHCP server never establishes any connection or a DHCP lease with any of the client devices.

Screenshot of settings

#13

Ok so you are doing everything wrong :slight_smile:

  1. You don’t need to disable the WAN port as that’s your actual internet connection from your ISP. leave it as DHCP, with not additional parameters specified. Remove that IP from the Router modem IP. that has nothing to do with your network.
  2. Leave the LAN DHCP as it is (disabled).
  3. in your Pi-hole, set the range from ABOVE 12 as that’s the IP of your Pi-hole.
  4. Your clients already have IPs assigned under a lease from the router. That’s why they are not showing in your list. In order for the client to get a new lease you have to force an release renew.
#17

Apologies if I didn’t make it clear, the settings I currently have are the settings in the screenshots. So most of the settings you recommended I already tried. The text on the side are things I’ve tried after the initial settings didn’t work. So I tried with the WAN/Internet “Type” as both DHCP and Disabled. I also tried it with “Type” as DHCP with and “Route Modem IP” as blank (0.0.0.0) and the RPI’s address (192.168.1.12).

I rebooted the PiHole and the router and I even forced a DHCP release in the router and ipconfig /release + ipconfig /renew on the client machine and the PiHole still does not recognize or see any client devices or DHCP leases.

-edit-

So it turns out rebooting the router from the Router interface is not as effective for renewing DHCP leases and manually unplugging and plugging the router back in works. I am now using the PiHole as the DHCP server.

However it doesn’t look like the clients are using the PiHole’s DNS. In the Admin console, there is still only 1 client.

-edit final-
So I could never figure out why the Pihole was not working as normally so I just reformatted my RPi (there were a lot of old/broken dependencies there) and just reinstalled Pihole. I spent the whole day trying to figure out the issue and if I just did the “nuclear” option in the first place, I would have saved myself the entire day.

Ending solution: wipe RPI, reinstall OS + Pihole + backups

Thread can be closed.