Can’t add to blocking list

Regarding to this post that is closed:

I notice that the behavior comes from some google applications, I just setup a new iPhone and notice that the logs are been registered since I installed 4 Google applications, Google Keep, Maps, Home and Translate.

Also I find a way to block the domain with the following regex:

Hope it helps.


There is no need to block such a domain, since it can't exist on the internet and will return NXDOMAIN if queried.


** server can't find NXDOMAIN

That's the fist query I did but didn't work because the app is sending the uri as '' but not '' or ''

Tested here:

1 Like

Pihole does not block on URL level but on domain level only. It can only block'

1 Like

beautiful :star_struck:

This what the logs looks like:

Without the regex filter filter and on the on the gravity filter list

With the regex enabled

It's an interesting behavior, I' not sure why is been resolved by pi-hole.

There is nothing unusual happening here. If you block the domain, it returns NULL for the IP. If you don't block it, the domain is not resolved because it doesn't exist on the internet. Either way, the requesting client doesn't get an IP in response to the request.

The query for is likely caused by some application created using a faulty firebase SDK.

While it doesn't make sense to query a DNS server for a URL, it's also nothing to worry about.
As jfb has pointed out multiple times now, URLs will never resolve to anything with DNS, so there is also no need to block them.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.