Bell Home Hub 3000 Setup Problems

I've been using Pi-Hole for some time now, and love it. Thank you for this amazing program!

Just recently, I upgraded my internet. I used to have a R3000 router, and set the primary & secondary DNS manually as the static IP of my Pi-Hole RPi (192.168.2.143). This worked perfectly.

Now, I have a new router - the "Home Hub 3000" from Bell Aliant. This operates my home phone & television as well. This is a screenshot of my advanced options menu:

When I go into my DNS settings, and manually set the primary & secondary server as my RPi, after a few minutes my home phone goes down:

When I look at my DHCP settings, I see nothing that would set the DNS:

Now I'm left either blocking ads or having home phone. Not both. And I'd really rather set this up in the router and not manually on every device/phone in the house... Any advice?

1 Like

Yeah, looks like that router doesn't let you change the DNS server.

The first idea that comes to mind is the new ability to have Pi-hole function as the DHCP server for your network. Take a look at the settings page.

Alternatively, maybe there is different firmware you can use with that router (DD-WRT or OpenWRT, etc.).

1 Like

Thank you, telekrmor. Sorry my reply is late - xmas time craziness.

I took your advice (I didn't know about this new setting). I'll entered my info as such:

But alas, it didn't seem to work on any of my connected devices. I didn't make any changes in my router - to be honest, I don't see how the pi-hole could act as my routers DHCP server, without my routers knowledge. But I'm not the best with advanced network setups.

In the meantime, I have manually set my main devices to use Pi-Hole as the DNS, but I loved the ability to inform guests that they'd enjoy ad-free wifi when visiting my house, lol. I can still set their devices, but not as cool :frowning:

Disable the DHCP server of your router. The Pi-hole will take care for you about all DHCP business in your network and your router will only be used as gateway to the internet.

Of course facepalm Thank you, DL6ER!

@darcnl I know this is a old post, but for my HomeHub 300 all I have to do is press Change on the Manually specify DNS information page and enter the routers serial number and that unlocks the settings.

I know this is an even older post now, but does that work for you? For me it doesn't accept local ips.

Same problem here even if I enter the local IP of my pihole it still uses the default Bell DNS IP as secondary and therefore is making my pihole useless because it prioritizes the fastest one I believe.

1 Like

I contacted bell support, they said local IPs are only supported on business plan routers.

2 Likes

Maybe its too to reply but I was having same problem and I have fixed it by disabling DHCP from my router and enabling DHCP from Pi-hole.

Thanks for posting this. I have recently upgraded and have the same modem / router as you. I was scratching my head as to where the settings were. I guess my pi-hole will become my dhcp server soon.

I am trying to setup pi hole with my bell hub 3000 modem. When I disable DHCP on the modem and enable it on the pi-hole, 2 things happen:-

  1. I can't connect to internet from my pi.

  2. When I access internet from any other device, ads still show. The pi-hole settings are as below



    Is there some other settings that I need to do?

I am having the same issue. When I disable DHCP on the modem and enable it on the pi-hole, the ads are still showing. My settings are the same as your screenshots. Were you able to get it working?

Unfortunately, not. Let me know if you were able to get it working

You will have to wait for the DHCP lease to renew on each device. The default for the Bell Router is 3 days. So It will take up to 3 days for a device to make a request for a new IP address, then the piHole will send the new DNS info along with the IP info.

You can skip the wait by manually renewing the IP lease on each device.

It is working now after manually renewing the lease on each device! Thank you

I retried all the steps and it still does not work for me. When I try to manually renew dhcp lease on my pc, I get error as per the screenshot. Can anyone provide any further insight?

How do u guys connect pinhole to the router? Via wifi or Ethernet? Does it make a difference?

@odogg , I am still struggling with the setup. Could you please advice if you connected your pihole via wifi or ethernet? Also, did you do anything different than the 2 steps mentioned by me? For e.g. did you have to setup any static ip. Did you change the ip range on your pi -hole or did you go with the default. Thanks.

I have a raspberry pi zero so it is connected by wifi. All I did was enable DHCP in the Pi-hole settings, type in the Bell modem's IP address in the Pi-settings under Router (gateway) address, and then turn off DHCP in the bell modem settings. Just like in your screenshots.

You need to restart the Bell modem for it to take effect. Then you need to renew the lease on all the devices connected to your network.

Assuming you did all of that, the error message you are getting may be due to a different issue. There are some troubleshooting steps in this article that might help like resetting the winsock catalogue.

https://answers.microsoft.com/en-us/windows/forum/windows_7-networking/i-get-an-error-media-disconnected-when-i-try-to/e0541113-cc92-40e6-84fa-1ebb8ac0fd24