Asus RT-AC87U


#1

Please follow the below template, it will help us to help you!

After about 10 minutes I’m getting 15k queries.

I’ve got the PiHole DNS set to my router.

In the LAN and WAN settings on my router I’ve got the IP of the PiHole in the DNS #1 settings.

I’ve got “Forward local domain queries to upstream DNS” turned on, which seems to help it work, and I’ve got 8.8.8.8 as the secondary DNS in both options because otherwise it seems I get no internet access from anything.

anyone with the same router care to share your config? I’m using asuswrt merlin.

debug log: uploaded - token below

Expected Behaviour:

[Replace this text with what you think should be happening]

Actual Behaviour:

[replace this text with what is actually happening]

Debug Token:

7unod6n9u0


#2

First you put twice in the upstream DNS the local address. If Pi-hole is running on the Asus then twice 192.168.2.62.

The clients should receive the new DNS (Pi-hole) when renewing there IP.

If that works you also force the router self to use Pi-hole. If your Pi-hole is running on the router then that could be the 127.0.0.1 address.


#3

Is there a reason you have Pi-Hole using the router as the upstream DNS server? You can use Google or your preferred upstream server in Pi-Hole and not send DNS traffic back to the router.

The screen capture of the dashboard doesn’t account for that level of traffic - do you have some domains excluded from the top lists (Admin GUI > settings > API/Web interface)?


#5

I’ve just been playing with the settings and changing things
until it worked. Some settings I was getting 0 domains blocked on
pihole, other times my entire internet connection wouldn’t work.

  The other guy says "First you put twice in the upstream DNS the

local address. If Pi-hole is running on the Asus then twice
192.168.2.62."

Like, I have no idea what this even means.


#6

The other guy says, that is in the second screen you put up here.

Upstream means to the outside on the Internet. You have Pi-hole running on your router if I am not wrong. This means that clients get told to use the Pi-hole and that Pi-hole gets the DNS resolution upstream.

If you had two Pi-holes then you could use the different addresses in the DNS server but you have only one.

Many router want to have two address given and to avoid the reply question, I can’t confirm the changed settings in the page, I advise to put twice the same value in the fields.


#7

“First you put twice in the upstream DNS the local address. If Pi-hole is running on the Asus then twice 192.168.2.62.”

why would I put the same DNS address twice in the upstream? if upstream #1 doesn’t work (it doesn’t) then my whole network fails and I get no internet connection. I have to put google DNS in the 2nd DNS server in order to get an outside connection, even though it does appear to be blocking things now. Hold on, let me disconnect my my VPN on my PC and test the phiole test page.

Seems to be working and blocking ads with my desktop (PIA VPN) app turned off, but that could be cached domains etc so I’ll reboot and update.


#8

That is not your Asus, that is Pi-hole on the Asus.

That is why I gave specific instructions. In screen 4 (you put up) you can choose one of the DNS servers in the left column.

The DNS in the DHCP (router settings Asus, screen 2) you put twice the Pi-hole 192.168.2.62 and if your clients go through the Pi-hole and resolve you also change the DNS in screen 3.


#9

sorry but the whole screen 1 2 4 blabla just tell me what setting it is don’t refer to my screenshots they are merely for your informational purposes.


#10

I don’t know Asus routers so your screenshots are the only information I can go on and so a reference for me.

I am not support and I can’t see any uploaded debug information so I have to what I read in this thread.

You have now 4 screens uploaded. In screen 3 you replace the current DNS setting by 192.168.2.62 as soon as your clients are working with these settings (tag google by example), in the left column of screen 4.
Nothing in the right column…no 192.168.2.2#53 or 8.8.8.8#53.

Then you can point th DNS of the router itself to the Pi-hole and that is done in screen 2.


#11

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.