Asus AC68


#82

As you can see from ip a, interface eth0 is still reported as disconnected without IP address.
Ty edit that /etc/dhcpcd.conf file and change ‘eth0’ into ‘wlan0’, save and reboot to test if the system comes up with network.

sudo nano /etc/dhcpcd.conf

After reboot, check again with ip a.
And if successful, you can try edit that /etc/dhcpcd.conf file again to alter ip_address into 10.1.1.3 + reboot + reconfigure Pi-hole etc.


#83


#84

So change all instances of eth0 in that conf file to wlan0?


#85

There should only be one “interface eth0” instance.
Change it into “interface wlan0” etc etc.


#86

From screenshot, it appears you dont have settings to configure upstream WAN DNS servers.
These DNS servers are probably supplied via the DSL connection.


#87

OK, not sure I understand very much of that. So where does that leave us? I have change interface eth0 to wlan0 and am in the process of rebooting.


#88

pi@PiHole:~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether b8:27:eb:dd:0c:bf brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:88:59:ea brd ff:ff:ff:ff:ff:ff
inet 10.1.1.240/24 brd 10.1.1.255 scope global wlan0
valid_lft forever preferred_lft forever
inet6 fe80::c275:c91:b0e:89c9/64 scope link
valid_lft forever preferred_lft forever
pi@PiHole:~ $


#89

Am I now ready to go on to the above do you think?


#90

Looks good.
Now you can try alter

static ip_address=10.1.1.240/24

into:

static ip_address=10.1.1.3/24

to change IP + reboot + reconfigure Pi-hole with nameserver hack.


#91

Hmmmm! when it ran through the reconfigure, it still showed 10.1.1.240 (even though I had rebooted!)…I must be doing something wrong and causing cascading problems

in the reconfigure…I can’t believe it can be this complex, so I must be misunderstanding your instructions through lack of experience/knowledge…sorry!..and now it has hung before it completed!!


#92

below one ?

ip a

Did ip address change ?


#93

It did not seem to …as it flashed through it showed 10.1.1.240 as the PI IP.

pi@PiHole:~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether b8:27:eb:dd:0c:bf brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:88:59:ea brd ff:ff:ff:ff:ff:ff
inet 10.1.1.240/24 brd 10.1.1.255 scope global wlan0
valid_lft forever preferred_lft forever
inet6 fe80::c275:c91:b0e:89c9/64 scope link
valid_lft forever preferred_lft forever
pi@PiHole:~ $


#94

sudo systemctl status dhcpcd -l

journalctl -u dhcpcd

?


#95

pi@PiHole:~ $ sudo systemctl status dhcpcd -l
● dhcpcd.service - dhcpcd on all interfaces
Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled; vendor preset: e
Active: active (running) since Wed 2019-03-13 22:34:38 NZDT; 8min ago
Process: 341 ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -b (code=exited, status=0/SU
Main PID: 354 (dhcpcd)
CGroup: /system.slice/dhcpcd.service
├─354 /sbin/dhcpcd -q -b
└─523 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iw

Mar 13 22:34:42 PiHole dhcpcd[354]: wlan0: carrier acquired
Mar 13 22:34:42 PiHole dhcpcd[354]: wlan0: IAID eb:88:59:ea
Mar 13 22:34:42 PiHole dhcpcd[354]: wlan0: adding address fe80::c275:c91:b0e:89c
Mar 13 22:34:43 PiHole dhcpcd[354]: wlan0: rebinding lease of 10.1.1.240
Mar 13 22:34:43 PiHole dhcpcd[354]: wlan0: probing address 10.1.1.240/24
Mar 13 22:34:43 PiHole dhcpcd[354]: wlan0: soliciting an IPv6 router
Mar 13 22:34:49 PiHole dhcpcd[354]: wlan0: leased 10.1.1.240 for 86400 seconds
Mar 13 22:34:49 PiHole dhcpcd[354]: wlan0: adding route to 10.1.1.0/24
Mar 13 22:34:49 PiHole dhcpcd[354]: wlan0: adding default route via 10.1.1.1
Mar 13 22:34:56 PiHole dhcpcd[354]: wlan0: no IPv6 Routers available
lines 1-19/19 (END)


#96

pi@PiHole:~ $ journalctl -u dhcpcd
– Logs begin at Fri 2016-11-04 06:16:42 NZDT, end at Wed 2019-03-13 22:43:21 NZ
Mar 13 22:34:38 PiHole systemd[1]: Starting dhcpcd on all interfaces…
Mar 13 22:34:38 PiHole dhcpcd[341]: dev: loaded udev
Mar 13 22:34:38 PiHole dhcpcd[341]: forked to background, child pid 354
Mar 13 22:34:38 PiHole systemd[1]: Started dhcpcd on all interfaces.
Mar 13 22:34:39 PiHole dhcpcd[354]: eth0: waiting for carrier
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: waiting for carrier
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: carrier acquired
Mar 13 22:34:39 PiHole dhcpcd[354]: DUID 00:01:00:01:23:7d:9b:32:b8:27:eb:88:59:
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: IAID eb:88:59:ea
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: adding address fe80::a431:1863:fefe:2
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: carrier lost
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: deleting address fe80::a431:1863:fefe
Mar 13 22:34:42 PiHole dhcpcd[354]: wlan0: carrier acquired
Mar 13 22:34:42 PiHole dhcpcd[354]: wlan0: IAID eb:88:59:ea
Mar 13 22:34:42 PiHole dhcpcd[354]: wlan0: adding address fe80::c275:c91:b0e:89c
Mar 13 22:34:43 PiHole dhcpcd[354]: wlan0: rebinding lease of 10.1.1.240
Mar 13 22:34:43 PiHole dhcpcd[354]: wlan0: probing address 10.1.1.240/24
Mar 13 22:34:43 PiHole dhcpcd[354]: wlan0: soliciting an IPv6 router
Mar 13 22:34:49 PiHole dhcpcd[354]: wlan0: leased 10.1.1.240 for 86400 seconds
Mar 13 22:34:49 PiHole dhcpcd[354]: wlan0: adding route to 10.1.1.0/24
Mar 13 22:34:49 PiHole dhcpcd[354]: wlan0: adding default route via 10.1.1.1
Mar 13 22:34:56 PiHole dhcpcd[354]: wlan0: no IPv6 Routers available
lines 1-23…skipping…
– Logs begin at Fri 2016-11-04 06:16:42 NZDT, end at Wed 2019-03-13 22:43:21 NZ
Mar 13 22:34:38 PiHole systemd[1]: Starting dhcpcd on all interfaces…
Mar 13 22:34:38 PiHole dhcpcd[341]: dev: loaded udev
Mar 13 22:34:38 PiHole dhcpcd[341]: forked to background, child pid 354
Mar 13 22:34:38 PiHole systemd[1]: Started dhcpcd on all interfaces.
Mar 13 22:34:39 PiHole dhcpcd[354]: eth0: waiting for carrier
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: waiting for carrier
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: carrier acquired
Mar 13 22:34:39 PiHole dhcpcd[354]: DUID 00:01:00:01:23:7d:9b:32:b8:27:eb:88:59:
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: IAID eb:88:59:ea
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: adding address fe80::a431:1863:fefe:2
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: carrier lost
Mar 13 22:34:39 PiHole dhcpcd[354]: wlan0: deleting address fe80::a431:1863:fefe
Mar 13 22:34:42 PiHole dhcpcd[354]: wlan0: carrier acquired
Mar 13 22:34:42 PiHole dhcpcd[354]: wlan0: IAID eb:88:59:ea
Mar 13 22:34:42 PiHole dhcpcd[354]: wlan0: adding address fe80::c275:c91:b0e:89c
Mar 13 22:34:43 PiHole dhcpcd[354]: wlan0: rebinding lease of 10.1.1.240
Mar 13 22:34:43 PiHole dhcpcd[354]: wlan0: probing address 10.1.1.240/24
Mar 13 22:34:43 PiHole dhcpcd[354]: wlan0: soliciting an IPv6 router
Mar 13 22:34:49 PiHole dhcpcd[354]: wlan0: leased 10.1.1.240 for 86400 seconds
Mar 13 22:34:49 PiHole dhcpcd[354]: wlan0: adding route to 10.1.1.0/24
Mar 13 22:34:49 PiHole dhcpcd[354]: wlan0: adding default route via 10.1.1.1
Mar 13 22:34:56 PiHole dhcpcd[354]: wlan0: no IPv6 Routers available
~


#97

pi@PiHole:~ $ ?
bash: ?: command not found
pi@PiHole:~ $

Sorry…joke!..could not resist!


#98

Looks like dhcpcd is still acquiring IP details/lease via DHCP from your router instead of taking on the static IP address that you configured.

Below one again pls ?

grep -v '^#\|^$' /etc/dhcpcd.conf


#99

A sample configuration for dhcpcd.

See dhcpcd.conf(5) for details.

Allow users of this group to interact with dhcpcd via the control socket.

#controlgroup wheel

Inform the DHCP server of our hostname for DDNS.

hostname

Use the hardware address of the interface for the Client ID.

clientid

or

Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.

Some non-RFC compliant DHCP servers do not reply with this set.

In this case, comment out duid and enable clientid above.

#duid

Persist interface configuration when dhcpcd exits.

persistent

Rapid commit support.

Safe to enable by default because it requires the equivalent option set

on the server to actually work.

option rapid_commit

A list of options to request from the DHCP server.

option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes

Most distributions have NTP support.

option ntp_servers

Respect the network MTU. This is applied to DHCP routes.

option interface_mtu

A ServerID is required by RFC2131.

require dhcp_server_identifier

Generate Stable Private IPv6 Addresses instead of hardware based ones

slaac private

Example static IP configuration:

#interface wlan0
#static ip_address=192.168.0.10/24
#static ip6_address=fd51:42f8:caae:d92e::ff/64
#static routers=192.168.0.1
#static domain_name_servers=192.168.0.1 8.8.8.8 fd51:42f8:caae:d92e::1

It is possible to fall back to a static IP if DHCP fails:

define static profile

#profile static_eth0
#static ip_address=192.168.1.23/24
#static routers=192.168.1.1
#static domain_name_servers=192.168.1.1

fallback to static profile on eth0

#interface eth0
#fallback static_eth0

interface eth0
static ip_address=10.1.1.3/24
static routers=10.1.1.1
static domain_name_servers=127.0.0.1
interface eth0
static ip_address=10.1.1.240/24
static routers=10.1.1.1
static domain_name_servers=127.0.0.1


#100

pi@PiHole:~ $ grep -v '^#|^ /etc/dhcpcd.conf`

Nothing shows!


#101

T
p[;’-0quote=“dunbrokin, post:100, topic:18179”]
Nothing shows!
[/quote]

Yeah copying and pasting things here can be tricky sometimes.
Try below:

grep -v '^#\|^$' /etc/dhcpcd.conf