Asus AC68

I dont use/install desktops on any of my servers.
All is done through SSH and Bash.
If I need a graphical application that needs desktop support, I export my display on server to network and use X to run applications on from a remote PC/laptop/etc:

https://www.x.org/wiki/

That is certainly the ideal!..but for a novice like me…who does sporadic projects and forgets easily…VNC seems to work. I would certainly follow your suggested route if I were more experienced.

You can have both VNC and SSHd active … after you get in again :wink:

Given this experience, I think it would be a good idea!

Good night …thanks again for your patience and your help!

1 Like

Sorry about that!..I am back!

pi@PiHole:~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:dd:0c:bf brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:88:59:ea brd ff:ff:ff:ff:ff:ff
    inet 10.1.1.3/24 brd 10.1.1.255 scope global wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::c275:c91:b0e:89c9/64 scope link 
       valid_lft forever preferred_lft forever
pi@PiHole:~ $

Looks good.
Run below ones on Pi to enable the sshd daemon and start sshd for next time you lose VNC:

sudo systemctl enable ssh

sudo systemctl start ssh

From the pj-selgbuild client, you should now be able to ssh into Pi with:

ssh -l pi 10.1.1.3

Next configure Pi-hole to use the new 10.1.1.3 address by running reconfigure:

echo 'nameserver 8.8.8.8' | sudo tee /etc/resolv.conf

pihole -r

Reboot Pi to be sure and test from Pi and a client:

nslookup pi.hole 10.1.1.3

If that all works, you can try switching DHCP service from router to Pi-hole:

After the switch, reboot the pj-selgbuild client and run below ones on it to see if it picked up the new DHCP settings including the Pi DNS IP:

ip a

cat /etc/resolv.conf

nslookup pi.hole

If that looks good, reboot your other client devices to renew DHCP lease so they too start using the new DHCP service + ad blocking through Pi-hole’s DNS.

??? Where did the 240 come from now???

[i] Existing PHP installation detected : PHP version 7.0.33-0+deb9u3
[i] Repair option selected
[✓] Disk space check
[✓] Update local cache of available packages

[✓] Checking apt-get for upgraded packages… up to date!

[i] Installer Dependency checks…
[✓] Checking for apt-utils
[✓] Checking for dialog
[✓] Checking for debconf
[✓] Checking for dhcpcd5
[✓] Checking for git
[✓] Checking for iproute2
[✓] Checking for whiptail

[i] Performing reconfiguration, skipping download of local repos
[✓] Resetting repository within /etc/.pihole…
[✓] Resetting repository within /var/www/html/admin…
[i] Main Dependency checks…
[✓] Checking for cron
[✓] Checking for curl
[✓] Checking for dnsutils
[✓] Checking for iputils-ping
[✓] Checking for lsof
[✓] Checking for netcat
[✓] Checking for psmisc
[✓] Checking for sudo
[✓] Checking for unzip
[✓] Checking for wget
[✓] Checking for idn2
[✓] Checking for sqlite3
[✓] Checking for libcap2-bin
[✓] Checking for dns-root-data
[✓] Checking for resolvconf
[✓] Checking for libcap2
[✓] Checking for lighttpd
[✓] Checking for php7.0-common
[✓] Checking for php7.0-cgi
[✓] Checking for php7.0-sqlite3

[✓] Enabling lighttpd service to start on reboot…

[i] FTL Checks…

[✓] Detected ARM-hf architecture (armv7+)
[i] Checking for existing FTL binary…
[i] Latest FTL Binary already installed (v4.2.3). Confirming Checksum…
[i] Checksum correct. No need to download!
[✓] Checking for user ‘pihole’
[✓] Installing scripts from /etc/.pihole

[i] Installing configs from /etc/.pihole…
[i] Existing dnsmasq.conf found… it is not a Pi-hole file, leaving alone!
[✓] Copying 01-pihole.conf to /etc/dnsmasq.d/01-pihole.conf

[i] Installing blocking page…
[✓] Creating directory for blocking page, and copying files
[✗] Backing up index.lighttpd.html
No default index.lighttpd.html file found… not backing up

[✓] Installing sudoer file

[✓] Installing latest Cron script

[✓] Installing latest logrotate script
[i] Backing up /etc/dnsmasq.conf to /etc/dnsmasq.conf.old
[✓] man pages installed and database updated
[i] Testing if systemd-resolved is enabled
[i] Systemd-resolved is not enabled
[✓] Restarting lighttpd service…
[✓] Enabling lighttpd service to start on reboot…
[i] Restarting services…
[✓] Enabling pihole-FTL service to start on reboot…
[✓] Restarting pihole-FTL service…
[✓] Deleting existing list cache
[i] Pi-hole blocking is enabled
[i] Neutrino emissions detected…
[✓] Pulling blocklist source list into range

[i] Target: raw.githubusercontent.com (hosts)
[✓] Status: Retrieval successful

[i] Target: mirror1.malwaredomains.com (justdomains)
[✓] Status: Retrieval successful

[i] Target: sysctl.org (hosts)
[✓] Status: Retrieval successful

[i] Target: zeustracker.abuse.ch (blocklist.php?download=domainblocklist)
[✓] Status: Retrieval successful

[i] Target: s3.amazonaws.com (simple_tracking.txt)
[✓] Status: Retrieval successful

[i] Target: s3.amazonaws.com (simple_ad.txt)
[✓] Status: Retrieval successful

[i] Target: hosts-file.net (ad_servers.txt)
[✓] Status: Retrieval successful

[✓] Consolidating blocklists
[✓] Extracting domains from blocklists
[i] Number of domains being pulled in by gravity: 134824
[✓] Removing duplicate domains
[i] Number of unique domains trapped in the Event Horizon: 112381
[i] Number of whitelisted domains: 0
[i] Number of blacklisted domains: 2
[i] Number of regex filters: 0
[✓] Parsing domains into hosts format
[✓] Cleaning up stray matter

[✓] Force-reloading DNS service
[✓] DNS service is running
[✓] Pi-hole blocking is Enabled

[i] The install log is located at: /etc/pihole/install.log
Update Complete!

Current Pi-hole version is v4.2.2
Current AdminLTE version is v4.2
Current FTL version is v4.2.3
pi@PiHole:~ $ nslookup pi.hole 10.1.1.3
Server: 10.1.1.3
Address: 10.1.1.3#53

Name: pi.hole
Address: 10.1.1.240

pi@PiHole:~ $

Ooops! did not do the reboot! :frowning:

Hmmm! even after the reboot 240 still comes up? what am I doing wrong?

pi@PiHole:~ $ nslookup pi.hole 10.1.1.3
Server: 10.1.1.3
Address: 10.1.1.3#53

Name: pi.hole
Address: 10.1.1.240

pi@PiHole:~ $

When you did run reconfigure pihole -r, did you select the correct interface wlan0 ?
And further on, were you not asked to use your current network settings ?
What did you reply here (yes/no) and what IP address was displayed here ?

Can you post outcome for below ones again pls ?

ip a

grep -v '^#\|^$' /etc/dhcpcd.conf

grep 'IPV[4,6]_ADDRESS\|PIHOLE_INTERFACE' /etc/pihole/setupVars.conf

sudo grep -v '^#\|^$' -R /etc/dnsmasq.*

It might be that your desktop runs some kind of network manager that messes things up.

Ohw if some network manager is messing, below one might reveal:

sudo grep 10.1.1.240 -R /etc/

Ooops! I just realised the problem…I ran this late last night…and was distracted by somebody at the crucial moment and so hit repair instead of reconfigure…my bad! Sorry! Back to square 1 and I will start again!

Yeah I noticed later :smiley:

But you could check below ones anyway to search for rouge network managers:

sudo grep 10.1.1.240 -R /etc/

sudo grep 10.1.1.240 -R ~

OK will do…but I seem to have screwed something up…

pi@PiHole:~ $ nslookup pi.hole 10.1.1.3
;; connection timed out; no servers could be reached

pi@PiHole:~ $ nslookup pi.hole 10.1.1.3
;; connection timed out; no servers could be reached

pi@PiHole:~ $

i@PiHole:~ $ sudo grep 10.1.1.240 -R /etc/
/etc/pihole/setupVars.conf.update.bak:IPV4_ADDRESS=10.1.1.240/24
Binary file /etc/pihole/pihole-FTL.db matches
grep: /etc/xdg/menus/debian-menu.menu: No such file or directory
pi@PiHole:~ $

pi@PiHole:~ $ sudo grep 10.1.1.240 -R ~
/home/pi/.bash_history:nslookup pi.hole 10.1.1.240
/home/pi/.bash_history:nslookup pi.hole 10.1.1.240
/home/pi/.bash_history:nslookup pi.hole 10.1.1.240
/home/pi/.bash_history:nslookup pi.hole 10.1.1.240
/home/pi/.bash_history:nslookup doubleclick.com 10.1.1.240
/home/pi/.bash_history:nslookup doubleclick.com 10.1.1.240
/home/pi/.bash_history:nslookup pi.hole 10.1.1.240
/home/pi/.bash_history:Address: 10.1.1.240
/home/pi/.bash_history:Address: 10.1.1.240
grep: /home/pi/.config/chromium/SingletonSocket: No such device or address
grep: /home/pi/.config/chromium/SingletonLock: No such file or directory
grep: /home/pi/.config/chromium/SingletonCookie: No such file or directory
Binary file /home/pi/.cache/chromium/Default/Cache/fbaa933085a87bd4_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/2e81c4aad91c1f2d_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/fd653fb681bcf3cf_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/8d456cf67f45dee1_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/a97acc30ca9a21a6_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/41713889aff6a0bb_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/48989a7c5c459b25_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/0b7434e706fb386d_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/d4997fcfcb3647f4_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/99b300bcfeef7415_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/2da011308356521b_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/7210dc73abff25b4_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/d24ef9a5367b0ec7_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/d281e22bc049abe8_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/1b5aadf6d7f54fdf_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/5e47db3b8ef8019f_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/153e865d406e5acc_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/dc98315f4510e77b_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/54b057d05bc081df_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/88b5cdc5c775f084_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/af060759f04af1cf_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/427a6e89c4b58242_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/8597bba19d2bed7b_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/ef4c95b86dc17835_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/eb2167dd54296054_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/db0a2a3f3afe7170_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/e563ee4d9d48dc9c_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/179145ec1411bc03_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/f15b4cf27f567ede_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/a5a62194c3d9b54d_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/6eec3e3eec2114fc_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/543bb0b7148a8c6f_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/d207080be8ed0264_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/e6658c4dc43d36d7_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/e965cf226586295e_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/ce03a81a52e7921a_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/999dbdc5735d0d96_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/3218fe2a01152b75_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/114ac8c4153f7ac6_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/2c9ac0400ac472a3_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/047cbd7acb303f33_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/bda48645e28aaddc_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/dbd94f2086b86a43_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/22942176aec66e74_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/3a035fe9d7b350c1_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/a261507c58138a1f_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/9e6461cfe3cac015_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/2f6f4728904c00fa_0 matches
Binary file /home/pi/.cache/chromium/Default/Cache/959a13a09a6725b8_0 matches
Binary file /ho

Try these ones:

grep -v '^#\|^$' /etc/dhcpcd.conf

grep 'IPV[4,6]_ADDRESS\|PIHOLE_INTERFACE' /etc/pihole/setupVars.conf

sudo grep -v '^#\|^$' -R /etc/dnsmasq.*

pi@PiHole:~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether b8:27:eb:dd:0c:bf brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:88:59:ea brd ff:ff:ff:ff:ff:ff
inet 10.1.1.3/24 brd 10.1.1.255 scope global wlan0
valid_lft forever preferred_lft forever
inet6 fe80::c275:c91:b0e:89c9/64 scope link
valid_lft forever preferred_lft forever
pi@PiHole:~ $ grep -v ‘^#|^$’ /etc/dhcpcd.conf
hostname
clientid
persistent
option rapid_commit
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
option ntp_servers
option interface_mtu
require dhcp_server_identifier
slaac private
interface wlan0
static ip_address=10.1.1.3/24
static routers=10.1.1.1
static domain_name_servers=127.0.0.1
pi@PiHole:~ $

…but I definitely chose wlan0!! in the reconfigure??

pi@PiHole:~ $ grep ‘IPV[4,6]_ADDRESS|PIHOLE_INTERFACE’ /etc/pihole/setupVars.conf
PIHOLE_INTERFACE=eth0
IPV4_ADDRESS=10.1.1.3/24
IPV6_ADDRESS=
pi@PiHole:~ $