All cellphone requests going throught www.google.com

I have a similar problem as this topic, 99% of the requests from both my Android cellphones (S8 and S9) go to www.google.com, rendering Pi-hole useless for them.

It’s not a Pi-hole misconfiguration, it’s working fine for other devices.

Just for clarification, all apps i use or sites i connect (even using Firefox to access duduckgogo.com) end up querying to www.google.com, so Pi-hole can’t block the real addresses because they’re going throught google…

Someone had a problem like this? How to turn this off?

You are probably using Lite Mode in Chrome on your Android device. This routes all traffic via Google to compress it and use less data. Try using a different browser on Android or disabling Lite Mode in Chrome Settings > Advanced > Lite Mode. Firefox Focus for Android allows adding the uBlock Origin extension btw…

Another option if you have the capability within your router to adjust firewall rules is to drop all DNS requests except your pihole. This works effectively on my network with devices that have a hardcoded DNS etc.