Ads not blocked - IPv6 problem?

Expected Behaviour:

After setting up it should be blocking ads

Actual Behaviour:

It does not block ads, see this example from reddit.com:

Debug Token:

Your debug token is: https://tricorder.pi-hole.net/h41bsirh2t

The output of my ipconfig:

   DHCP Server . . . . . . . . . . . : 192.168.178.16
   DNS Servers . . . . . . . . . . . : 2001:b88:1002::10
                                       2001:b88:1202::10
                                       2001:730:3e42:1000::53
                                       192.168.178.16

The PiHole is the DHCP server.
The problem is with IPv6 I suppose, but how can I solve it?

None of these IPv6 addresses are your Pi-Hole. These are likely being provided by the ISP via your router. If you disable IPv6 on the router and clients, this typically resolves the problem. Very few users need IPv6 and an IPv6 DNS request can be resolved by IPv4.

The IPv6 addresses shown are public addresses so not really suited to be used .

Look on your raspberrypi (ifconfig) for a address beginning with fe80: , which is local. Put that in your DNS client setting or the device acting as DHCP.

I’m using a router from my provider, I can’t change the DNS settigns there at all. Is there another solution?

You are already using Pi-Hole as DHCP. There are a few things you can do.

On the client from which you showed the ipconfig, go to the IPv6 setting for that network interface and disable it.

On your Pi-Hole, tidy up the IPv6 addresses. From your debug log, you have multiple IPv6 addresses, but none match what Pi-Hole is configured to use:

[✓] IPv6 address(es) bound to the eth0 interface:
   2001:1c04:2404:1000:f31:b391:b60c:7b20 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)
   fe80::925a:3409:9fa8:e484 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)

    IPV6_ADDRESS=2001:1c04:2404:1000:f53d:cfe2:bb2f:a097

I had the same issue as you, with a router with unchangeable DNS settings, which caused Android devices to have the same symptoms you described. In my case, although I wasn’t able to change DNS settings, I was able to disable IPv6 on my router. That completely solved my problem.

Hope this helps.