Admin interface unavailable - lighttpd running, cannot restart

lighttpd
#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Admin interface should be running after upgrading

Actual Behaviour:

Admin interface NOT available, but shows to be running via console

Debug Token:

5mvtvvczx9

0 Likes

#2

I’ve recently upgraded to the latest and greatest, services started up fine, however, the admin interface is not accessible. Checking on the lighttpd service, it shows to be running:

[root@comp log]# systemctl status lighttpd
● lighttpd.service - Lightning Fast Webserver With Light System Requirements
   Loaded: loaded (/usr/lib/systemd/system/lighttpd.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2019-02-07 08:21:14 CST; 13min ago
 Main PID: 11086 (lighttpd)
   CGroup: /system.slice/lighttpd.service
           ├─11086 /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf
           ├─11089 /usr/bin/php-cgi
           ├─11090 /usr/bin/php-cgi
           ├─11091 /usr/bin/php-cgi
           ├─11092 /usr/bin/php-cgi
           ├─11093 /usr/bin/php-cgi
           ├─11094 /usr/bin/php-cgi
           ├─11095 /usr/bin/php-cgi
           └─11096 /usr/bin/php-cgi

Feb 07 08:21:14 comp systemd[1]: Stopped Lightning Fast Webserver With Light System Requirements.
Feb 07 08:21:14 comp systemd[1]: Started Lightning Fast Webserver With Light System Requirements.

Moreover, attempting to restart does NOT allow me to do so. In response, I’ve tried the resolution on this post, to no avail:

Stumped.

0 Likes

#3

What content or error message do you see in your browser when you go to the admin page? And what URL are you typing in your browser to visit?

0 Likes

#4
-rw-r--r-- 1 lighttpd lighttpd 581 Feb  7 08:11 /var/log/lighttpd/error.log
   2019-02-03 03:38:01: (server.c.1752) logfiles cycled UID = 0 PID = 56601 
   2019-02-06 18:27:35: (server.c.2052) server stopped by UID = 0 PID = 1 
   2019-02-06 18:30:25: (server.c.1457) server started (lighttpd/1.4.52) 
   2019-02-07 03:12:01: (server.c.1752) logfiles cycled UID = 0 PID = 7080 
   2019-02-07 08:05:55: (response.c.400) uri-path does not begin with '/': pihole/index.php -> 400 
   2019-02-07 08:11:53: (response.c.400) uri-path does not begin with '/': pihole/index.php -> 400 
   2019-02-07 08:11:54: (response.c.400) uri-path does not begin with '/': pihole/index.php -> 400 

@bcambl Is this a CentOS related issue?

0 Likes

#5

Using Firefox 65, I see a generic “unable to connect” https://i.imgur.com/RsUM9lW.png

I am using: hostname:custom-port/admin

0 Likes

#7

any thoughts or suggestions? tried updating, noticed FTL was out of date, updated fine except for this message:

[i] Warning: 'lighty-enable-mod' utility not found
  Please ensure fastcgi is enabled if you experience issues

Still unable to connect to the admin/web interface.

0 Likes

#8

What specific URL have you previously been using to connect to your admin GUI? Custom port was what?

Also, please upload a new debug log and post the token as your previous token has expired.

0 Likes

#9

previous URL: http://mideel:6045/admin

Debug token: lobgqz4ko3

0 Likes

#12

Your lighttpd version may be newer than the versions used in Debian stable, thus the error message here:

   2019-02-07 08:11:54: (response.c.400) uri-path does not begin with '/': pihole/index.php -> 400

Try editing this line in /etc/lighttpd/lighttpd.conf:

   server.error-handler-404    = "pihole/index.php"

to be this:

   server.error-handler-404    = "/pihole/index.php"
2 Likes

#13

@Mcat12

Thanks, that fixed the issue for me. I had also done an update to my Pi as well at the same time I updated pihole. There was no need to restart lighthttpd after editing the file.

0 Likes

#14

Thanks @Mcat12, tried that, however I still cannot access the front end. Are there any other changes, such as service restarts I should try? I’ve tried rebooting with no change.

0 Likes

#15

Fixed my issue. Turns out the update overwrites the admin interface port and sets to the default of ‘80’. changed this back to my custom port and voila! Thanks for the help!

For reference, I changed this line within /etc/lighttpd/lighttpd.conf:

from:
server.port = 80
To:
server.port = 6045

Issue command: “service lighttpd restart”, profit.

0 Likes

closed #16

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes