Admin gui, queries, and installion questions


#1

Brand new Pi-Hole user here. I installed it on a RPi 1 model B, with a fresh install with Jessie lite. Got it running, and pointed my main router DNS to the RPi’s IP. Seems to be working fine, as ads are getting blocked on the different devices I’ve tested. Now my questions:

  1. The admin page loads extremely slooooowwwwllly. I’ve read some of the posts on this help board, and I understand that this may be a common issue, and that a fix is being worked on by the developers. So I can understand and live with this. I was wondering if my RPi was underpowered being an older model.

  2. I have a couple of RPi model 3’s that are running other tasks (webserver, Nagios network monitoring, …). If I was to install pi-hole on one of these RPi’s innstead of my model B would I still have the same gui loading problem? And am I safe to install pi-hole on a system that is already running other services (and especially ones that are running webservers - I got the impression from some other posts that the pi-hole lighttpd webserver may mess up settings for other web servers).

  3. As I noted, I just installed this yesterday. An hour or so after installing, the admin page indicated there had been about 300,000 DNS queries! And today, at about 1pm, it tells me that there have been 2.4 million (!!!) DNS queries today. This kind of shocks me. I did a tail of the log, and here is a sample.

    Feb 26 13:41:09 dnsmasq[3540]: query[A] isatap.home from 192.168.2.1
    Feb 26 13:41:09 dnsmasq[3540]: cached isatap.home is NXDOMAIN
    Feb 26 13:41:09 dnsmasq[3540]: query[A] isatap.home from 192.168.2.1
    Feb 26 13:41:09 dnsmasq[3540]: cached isatap.home is NXDOMAIN
    Feb 26 13:41:09 dnsmasq[3540]: query[A] isatap.home from 192.168.2.1
    Feb 26 13:41:09 dnsmasq[3540]: cached isatap.home is NXDOMAIN
    Feb 26 13:41:09 dnsmasq[3540]: query[A] isatap.home from 192.168.2.1
    Feb 26 13:41:09 dnsmasq[3540]: cached isatap.home is NXDOMAIN
    Feb 26 13:41:09 dnsmasq[3540]: query[A] isatap.home from 192.168.2.1
    Feb 26 13:41:09 dnsmasq[3540]: cached isatap.home is NXDOMAIN
    Feb 26 13:41:09 dnsmasq[3540]: query[A] isatap.home from 192.168.2.1
    Feb 26 13:41:09 dnsmasq[3540]: cached isatap.home is NXDOMAIN
    Feb 26 13:41:09 dnsmasq[3540]: query[A] isatap.home from 192.168.2.1
    Feb 26 13:41:09 dnsmasq[3540]: cached isatap.home is NXDOMAIN
    Feb 26 13:41:09 dnsmasq[3540]: query[A] isatap.home from 192.168.2.1
    Feb 26 13:41:09 dnsmasq[3540]: cached isatap.home is NXDOMAIN
    Feb 26 13:41:09 dnsmasq[3540]: query[A] isatap.home from 192.168.2.1

The isatap.home shows up a ton. As does wpad.home. Not sure what’s going on here.

  1. Final question. You’ll notice from the above that the queries come from 192.168.2.1. This is the IP of my main router, the one where I set the DNS to point to the RPi with pi-hole on it. In fact, all the queries of any kind seem to come from that IP, even if they originate from another machine on my network. Is that the expected behaviour? If so, then there really is no way to know which machines are sending out the queries?

Thanks in advance for any assistance!


What Really Happens On Your Network? Find Out With Pi-hole
What Really Happens On Your Network? Redux
#2

I think this and this could be interesting for you.


#3

See here:

and here:

It will perform slightly better, but again, FTL will be the real answer. It should make the interface loadable on a Pi Zero.[quote=“yds, post:1, topic:1922”]
the admin page indicated there had been about 300,000 DNS queries!
[/quote]

You’re not the only one who has discovered something unexpected.

Do you have a Windows machine on your network? This is the Microsoft ISATAP adaptor for the IPv6 protocol.

Depending how you configured your router, this may be the behavior you see. If you set the DNS server in the DHCP or LAN options, this probably won’t happen.


#4

Thanks Vertux. I had seen the second of your links. But I’m still not clear if it something I should be concerned about, or do something about.


#5

I do in fact. It is my main webserver. I also have one other user who is on Windoze. Is there anything that I can/should do to reduce these queries? Is there any harm (other than filling up my pi-hole log) to letting these continue?? If I understand correctly from some other posts, queries that result in the “NXDOMAIN” response don’t go outside the network.


#6

I only seem to have one place on my router (it is a Bell Sagemcom 2864) that I can manually set the DNS. This is the screenshot.

The DHCP page on the router looks like this, and doesn’t have a separate spot to set a DNS here.


#7

It looks like that router doesn’t let you set a DNS server for your DHCP clients.

The best alternative to achieve the functionality you want, is to use Pi-hole’s built in DHCP server. It can be activated from the Settings page. If you do this, make sure you disable DHCP on your router.


#8

I suppose disabling the adapter might do the trick. If your router or gateway is handling the protocol, you may not need it.

It’s hard to say without understanding your entire network; you’ll probably have to investigate if it’s causing any issues. I’ve never understood the way Microsoft does things to begin with…


#9

I would love to do this. However, the Bell router is serving both my internet and my IPTV settings. When I’ve looked in the past to try set up my own separate DHCP server, other forums have indicated that it may screw up my IPTV (I have three different boxes throughout the house) and disable by TV viewing abilities, which would not please the other members of my network (a.k.a The Family!).

I will try disabling the IPV6 settings on both of the Windoze boxes on my system to see if that makes any difference.

Thanks for your assistance!!


#10

Here’s a part of my windows image using MDT that I use to disable ipv6 properly. Unchecking the ipv6 doesn’t do much. I found this command turns all the components off.

run via elevated dos prompt

disable 6to4

netsh interface ipv6 6to4 set state state=disabled

disable Teredo

netsh interface ipv6 set teredo disable

disable isatap

netsh interface ipv6 isatap set state state=disabled

These doesn’t have to be run in the order above. Hope it helps with the extra windows pc chatters.