Xbox app not working with pi-hole enabled

As above.
With pi-hole enabled the app won't start.
With it disabled it does.
Running in android
Any tips?

Thanks but I've already whitelisted all the Microsoft / Xbox specific ones?

Huh, strange.
After running a command, I got the following...

pi@pi-hole:/etc/pihole $ pihole -w
  [i] Adding to whitelist...
  [i] does not exist in blacklist, no need to remove!
  [i] does not exist in wildcard blacklist, no need to remove!

  [i] Using cached Event Horizon list...
  [i] 684,559 unique domains trapped in the Event Horizon
  [i] Number of whitelisted domains: 45
  [i] Number of blacklisted domains: 7
  [✓] Parsing domains into hosts format
  [✓] Cleaning up stray matter

  [✓] Force-reloading DNS service
  [✓] DNS service is running
  [✓] Pi-hole blocking is Enabled

And now it works...

1 Like

even more strange now.

Once again the app is not useable when Pi-Hole is enabled.

I have not added or modified my whitelist, nor my block list?

Can anyone help me diagnose this please?

It's probably worth-while to tail the log file to find out what domain(s) you may need to whitelist.

yeah I've tried this and nothing obvious jumps out at me.
although there is a strong possibility that im missing something...anything in particular I should be looking there any means to determining if a query is coming from a specific app?
Obviously there are multiple queries from my phone so pinning down the exact one(s) that are causing issues with one app is hard..?

I have reverted back to the standard default adlists.list so ill see if that works.
Its particularly puzzling, because when I am at home connected to my network, the app intermittently works.

When im out and on 4G, it works 100% of the time.

Looking at the timestamps can help quite a bit. Also watching the log in real time is useful. If there is too much chatter, you can stop other devices from talking to Pi-hole so the troublesome client is the only one showing up in the logs.

If you're not using a VPN+Pi-hole, your not using ad-blocking so there's no reason it would be blocked.

Yeah ive done this and not had any luck, maybe ill try turning every connected device off, so its only my Android phone on the network. The problem is (that I am having) is the phone is making many queries in the back ground etc

Yeah I know this, I only really pointed it out as it was part of my train of thought...I was starting to think that it was the app that was the problem, but given it works absolutely perfect when not connected to Pi-hole, and when I manually disable Pi-hole when connected to the network, im pretty confident that its not the app causing the issue.

Pi-hole itself can't tell which requests came from which app. There might be applications on the mobile device which can tell you that. Are there any blocked domains in the log right after you open the app?

I I feel a feature request coming on....:wink:

Ive found a couple of apps but they are prtty much garbage, and im unsure on their reliability...which means I don't trust them.

There are many. many many many. It seems to dial out a plethora of requests the second the app is opened.

Even more strange, once again, is last night the app was working.
reverted back to the default adlists.list and it worked.
Added Wallys lists, and it worked (previously it didn't)
Reverted back to the default adlists.list and it worked. For a bit. Then didn't. And this morning, it did.

I should point out my device has not been power cycled during any of this, nor has my pi-hole or ISP router.
And I haven't modified my whitelist or blacklists.

I am truly perplexed.

Could it be that the app itself is using blocked domains only some of the times its opened?

This might help in your endeavor ... or not :wink:
To start capturing the Pi-logs to a separate file just before opening the app:

tailf /var/log/pihole.log > capture.log

CTRL-C to break when you think you captured enough.

And below one will display domains queried nicely sorted and counted if you put the XBOX IP address in place:

grep <XBOX_IP_ADDRESS> capture.log | grep query | awk '{print $6}' | sort | uniq -c

1 Like

If your Xbox Party (Voice chat) is not working then whitelist Microsoft tunnels all their networks through Azure to protect against monitor abuse. Therefore, whitelisting has something to do with that connection and allows me to talk again.