Wrong used Time

#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

PiHole should use local (CET) time so it display the Queries correctly at Webinterface.

Actual Behaviour:

PiHole use UTC time instead of my in “sudo raspi-config” configured time for Germany. Because of that, PiHole querys in webinterface are 1 hour in the past

Debug Token:

a3gyqp2hcs

Optional Info:

i use Stubby for encrypted DNS

0 Likes

Use local device time instead of user browser time for query timeline
#2

What’s the output of command

timedatectl

On my system it shows

Local time: Sat 2019-02-16 15:16:43 CET
Universal time: Sat 2019-02-16 14:16:43 UTC
RTC time: n/a
Time zone: Europe/Berlin (CET, +0100)
Network time on: yes
NTP synchronized: yes
RTC in local TZ: no

I’m from Germany too and date/time in the Pi-hole Query Log are correct here.

0 Likes

#3

Output is:

Local time: Sa 2019-02-16 15:25:34 CET
Universal time: Sa 2019-02-16 14:25:34 UTC
RTC time: n/a
Time zone: Europe/Berlin (CET, +0100)
Network time on: yes
NTP synchronized: yes
RTC in local TZ: no

0 Likes

#4

and

tail -n1 /var/log/pihole.log

0 Likes

#5

Feb 16 15:45:38 dnsmasq[4429]: reply a-0001.a-msedge.net is NODATA-IPv6

0 Likes

#6

The web interface needs a correct time on the client as well, and some browsers also have a time setting.

0 Likes

#7

I dont’t get what you mean.
What have my browser (Firefox) and PiHole webinterface together?

0 Likes

#8

The web interface is being displayed on the client browser.

0 Likes

#9

Your’re right. My hardened firefox version displayed another time then a not hardened profile.
So no bug.

Thread can be closed then. Thanks for help

0 Likes

#10

I figured out, that the following Firefox about:config setting is the problem here:
privacy.resistFingerprinting

Is their a chance for using local Pi time, instead of user browser time at the webinterface? Would solve my problem and for all other guys which use this privacy feature in Firefox

0 Likes

#11

I have the same setting enabled on Firefox and I’m seeing the correct time in displayed query logs using that browser.

Edit - the same setting was disabled. When enabled, the time shown is UTC.

0 Likes

#12

What is your nativ UTC time?
Cause privacy.resistFingerprinting set it to UTC 0

My UTC is UTC +1 (Berlin)

0 Likes

#13

Mine is UTC -6.

0 Likes

#14

I stand corrected. The option was still on false. When I set it to true, I do see Pi-Hole queries in the log as UTC.

0 Likes

#15

I don’t believe this is the case. If this is something you would like to see implemented in Pi-Hole, please submit a feature request.

0 Likes

#16
0 Likes

closed #17

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes