Windows 10 showing no internet access but I am connected to the internet


#1

I’ve had my pihole set up and working fine for the last few weeks. I’m using the pihole to serve the DNS and again that seems to have been working with no issues.

This morning I turned on my computer (Windows 10 Pro) and the network icon in the notification centre is showing a yellow warning triangle saying that I have no internet access but I can use Chrome, Edge etc to browse fine. The only issue I have because of this is that all the Windows 10 apps won’t connect.

I’ve tried running the troubleshooter but after rebooting the problem still exists.

I’ve added all the Microsoft entries in the common whitelist list here (Commonly Whitelisted Domains) and they have been there since I installed the pihole a few weeks ago.

Debug Token:

zipwsngp15


#2

Try running pihole -r and reconfigure with only IPv4 support as it looks like you might not have real IPv6 internet connectivity. Also, try whitelisting msftncsi.com as well (there’s a difference between domains with and without www)


#3

Tried reconfiguring and double checking that that domain is whitelisted along with www.msftncsi.com.

I flushed the dns cache and restarted the computer but I’m still getting the triangle.


#4

Check the query log to see what is getting blocked.


#5

There isn’t really anything being blocked for my computer, there are a couple of google-analytics ones but I doubt that would be the issue?


#6

What did the troubleshooter say about the issue?


#7

It doesn’t say anything, it just resets the connection and asks me to reboot the computer.


#8

Check the queries generated while the troubleshooter is going. If it’s a blocked domain that’s the issue, then it would show up in that time period.


#9

Nothing showing in the log as being blocked.

I know it’s some issue with the pi-hole as it only happens when I’ve got the pi-hole set as a DHCP server.

If I disable it from being a DHCP server and use my router again the warning triangle goes away.


#10

Okay, I’ve just disabled the pi-hole from being a DHCP server, started using my router as the DHCP server, changed the computer’s DNS to point to the pi-hole’s IP address and the warning triangle has gone from the network icon.

I’ve no idea what the issue is with me using the pi-hole as a DHCP server. Maybe I’ve got some configuration wrong on my Banana Pi?

Guess I’ll just change the DNS on all my devices manually then?


#11

Sorry to get back to you so late. I’m not sure why the DHCP server would have caused that, since AFAIK the Windows internet check just relies on being able to get a certain response back from a certain MS domain.