Why are Adverts on Some Domains Not Blocked?


#1

Expected Behaviour:

Pi-Hole is operating successfully for many web sites.

Actual Behaviour:

However, I’ve noticed that some web sites (this one as an example - http://www.bom.gov.au/?ref=hdr) does not have it’s advertisements blocked by Pi-Hole. However, if someone clicks on the displayed advertisement, Pi-Hole successfully blocks the advert web site from opening. Do I have something configured incorrectly, or is there something unusual about the way that this web site is configured to serve up advertisements ?

Debug Token:

x8u4pup6da


Too many queries made when 'Conditional Forwarding' is enabled
#2

Do you have a secondary DNS server configured alongside Pi-hole somewhere ?
This is a common mistake as the clients will, depending on implementation, randomly choose a DNS server to query causing ads to still leak through.
If have just started using Pi-hole, clear browser cache and/or press “Ctrl + F5” on that page to refresh content.

Ps. I dont see a single ad on that page except for a link that says “Advertisement” :sunglasses:


#3

I can confirm this. I only use a standard Pi-hole installation (no extra blocking lists, no special settings, etc.)


#4

Thanks for that suggestion deHakkelaar.

I did “sudo nmap --script broadcast-dhcp-discover” to find out exactly what information the ASUS Router’s DHCP Service was handing out. The following is an extract of the output of that nmap command:

“Domain Name Server: 192.168.2.22, 192.168.2.1”

So, the ASUS Router’s DHCP Service is handing out an unwanted secondary DNS address, even though the Pi-Hole address is the only DNS service configured… My Pi-Hole Server is at 192.168.2.22, and the ASUS Router is at 192.68.2.1.

There doesn’t seem to be anyway to disable the ASUS Router’s own DNS in the Router’s web interface. I’ve been planning to change the ASUS Router over to DD-WRT to enable a few other additional features, so will install DD-WRT hoping that I will then get enough additional configuration flexibility in DD-WRT to enable me to disable the router’s DNS Service — or perhaps to install Pi-Hole on DD-WRT - but that idea needs more research - I’m not sure if it’s possible yet.

So, thanks again for your suggestion.

Regards,

RoyG


Pi Hole running fine, DNS server not showing pi hole IP. VPN also not working
#5

Can you disclose what model router ?
I have a model RT-N66U and experienced same as you did.
There is just no way to kill that second DNS IP coming from the router.
Maybe with future firmware updates but still … its just useless if DNS servers dont hold exactly the same DNS records and its confusing.
To fix, I disabled the DHCP server on the Asus router and replaced it with Pi-hole’s own DHCP service:


#6

The router concerned is an ASUS RT-AC68U.

I sent an email to ASUS Tech Support and they advised that disabling the router’s own DNS Service is not possible using the Router’s Web Interface, but is possible via the command line once you log in using the Router’s SSH service. However, ASUS support advised that as I had the earliest variant of the RT-AC68U, that SSH access was unreliable on the early variant.

Using Pi-Hole’s own DHCP Service instead of the ASUS Router’s own DHCP Service sounds like another viable alternative. I might try that prior to trying the DD-WRT firmware on the ASUS.

Thanks,

RoyG


#7

Wow you’ve got SSH.
I can only telnet into my Asus :wink:

But thats poor advice from Asus support … I think.
Chances are, if you run a firmware update, or maybe even when you change a setting via the web GUI, these SSH altered settings get reset back to default.

Ah well, Pi-hole’s DHCP has been running for close to a year now and am very happy with it.

EDIT: maybe you should have asked them what that DNS setting is intended for as I cant see any way of using these Asus settings with for example running your own DNS server.
One moment it resolves your personal records nicely and the next, it gets a NXDOMAIN response from the router.


#8

Problem solved. Enabled Pi-Hole’s own DHCP Service, and disabled Routers DHCP.

Thanks for all the valuable input.

RoyG