Whitelisting only one client


#1

I have an Amazon FireTv Stick running which is using GoogleAds for a lot of apps. The problem is that when the ads are blocked the screen stays black also not loading my desired video. So i need to whitelist the whole client.

How can i do so? (Pi-hole is the dhcp server in the network)
When i assign a static ip for the amazon stick and then work with iptables? Or is there an other solution?

Best regards


#2

Make a new conf in /etc/dnsmasq.d/

Etc name it sudo nano /etc/dnsmasq.d/nopie.conf

whit:

dhcp-option=tag:nopie,option:dns-server,1.1.1.1,1.0.0.1

In option:dns-server you can add the dns server you want to use.

dhcp-host=xx:xx:xx:xx:xx:xx,set:nopie,10.10.1.29,UnitName

Replace the xx:xx:xx:xx:xx:xx whit the real mac adress

Remember to restart dnsmasq when you are done.


#3

Thank you very much!! Worked like a charm


#4

I have been trying to get this to work without any luck. I have setup the config file for my wife’s computer but when I have it try to get an IP address (ipconfig /renew), it times out without getting the IP. When I comment out the entries in nopie, it works fine. I have a DHCP lease set up for her system, but I get the same results if I remove it.

Any suggestions?

nopie:
dhcp-option-tag:nopie,option:dns-server,1.1.1.1,1.0.0.1
dhcp-host=xx:xx:xx:xx:xx:xx,set:nopie,192.168.1.9,SHERYL-PC

xx has her real mac address.


#5

It is easier to just manually change her DNS server on the machine instead of through DHCP.