Whatsmydnsserver.com never works when using pi-hole

Ever since I started using Pi-Hole, the whatsmydnsserver.com has never worked with it. I have seen a couple of posts here and in the github issues forum that suggests it works for other people.

I have tried using whatsmydnsserver.com when using the standard version and the docker version and with different upstream DNS servers set, but it never works.

Does it work for you and does anybody have any idea why it does not work for me?

The site doesn't load for me at all. What information are you seeking on that site? Perhaps an alternate site can provide it.

It's supposed to show you what DNS server you used to access the site. It does not seem to work when using pi-hole.

It's especially useful for testing if a VPN connection is working correctly.

I do not know of any similar sites.

Pi-hole doesn't have that domain on it's default blocklists. It resolves to IP as it should.

The site it quite broken:

dschaper@MARINER-10:~$ curl -I https://whatsmydnsserver.com
curl: (7) Failed to connect to whatsmydnsserver.com port 443: Connection refused
dschaper@MARINER-10:~$ curl -I http://whatsmydnsserver.com
HTTP/1.1 502 internal error - server connection terminated
Date: Fri, 31 Jul 2020 15:30:42 GMT
Connection: keep-alive
Server: Microsoft-IIS/7.5
Cache-Control: no-store
Content-Type: text/html
Content-Language: en
Content-Length: 294

dschaper@MARINER-10:~$ dig whatsmydnsserver.com

; <<>> DiG 9.11.5-P4-5.1+deb10u1-Debian <<>> whatsmydnsserver.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11929
;; flags: qr rd ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;whatsmydnsserver.com.          IN      A

;; ANSWER SECTION:
whatsmydnsserver.com.   0       IN      A       184.168.221.6

;; Query time: 2 msec
;; SERVER: 172.30.64.1#53(172.30.64.1)
;; WHEN: Fri Jul 31 08:31:43 PDT 2020
;; MSG SIZE  rcvd: 74

Try http (no https) and it's actual web site domain.

dschaper@MARINER-10:~$ curl -I http://www.whatsmydnsserver.com
HTTP/1.1 200 OK
Server: nginx
Date: Fri, 31 Jul 2020 15:34:25 GMT
Content-Type: text/html
Content-Length: 9003
Connection: keep-alive
Vary: Accept-Encoding
Last-Modified: Mon, 27 Apr 2020 02:01:13 GMT
ETag: "232b-5a43c16f7e6b7"
Accept-Ranges: bytes
X-Httpd: 1
Host-Header: 8441280b0c35cbc1147f8ba998a563a7
X-Proxy-Cache-Info: DT:1
2 Likes

So, if you know the owner of this site tell them:

Enable TLS/SSL so https:// works, and fix their redirect from bare to www. as it's not correct.

Use https://www.whatsmydns.net/

That's a propagation checker.

Okay, it seems that the site isn't working at all, using pi-hole or not. I've used it in the past, so hopefully it will start working again some time. Cheers.

1 Like