Webadmin : 403 forbidden

Please follow the below template, it will help us to help you!

Expected Behaviour:

See the admin webpage_

Actual Behaviour:

403 forbidden_

Debug Token:

https://tricorder.pi-hole.net/8sk60cmuwk

Are you trying with /admin/ ?

*** [ DIAGNOSING ]: Operating system
[βœ“] Raspbian GNU/Linux 8 (jessie)

Jessie has not been supported for a long time now. The release is End Of Life and not supported by Raspberry Pi any more.

Well, I updated to stretch, the same

New debug token :

https://tricorder.pi-hole.net/yy6moqd05k

pihole

What is the exact URL you are using to access the web admin page?

Is this repeatable across different browsers?

Something is messed up with the /admin/ path under /var/www/html/admin

You will need to sudo rm -rf /var/www/html/admin and then run a pihole -r and repair.

Try this and let us know what the outcome is.

No help… Repair stops because it can’t find /var/www/html/admin

[i] Existing PHP installation detected : PHP version 7.0.33-0+deb9u3
[i] Repair option selected
[βœ“] Disk space check
[βœ“] Update local cache of available packages

[βœ“] Checking apt-get for upgraded packages… up to date!

[i] Installer Dependency checks…
[βœ“] Checking for apt-utils
[βœ“] Checking for dialog
[βœ“] Checking for debconf
[βœ“] Checking for dhcpcd5
[βœ“] Checking for git
[βœ“] Checking for iproute2
[βœ“] Checking for whiptail

[i] Performing reconfiguration, skipping download of local repos
[βœ“] Resetting repository within /etc/.pihole…
Unable to reset /var/www/html/admin, exiting installer

Go for Reconfigure :slight_smile: (sorry about that)

Reconfigure fails too.

 [i] Existing PHP installation detected : PHP version 7.0.33-0+deb9u3
  [i] Reconfigure option selected
  [βœ“] Disk space check
  [βœ“] Update local cache of available packages

  [βœ“] Checking apt-get for upgraded packages... up to date!

  [i] Installer Dependency checks...
  [βœ“] Checking for apt-utils
  [βœ“] Checking for dialog
  [βœ“] Checking for debconf
  [βœ“] Checking for dhcpcd5
  [βœ“] Checking for git
  [βœ“] Checking for iproute2
  [βœ“] Checking for whiptail

  [i] Using Cloudflare
  [i] Static IP already configured
  [i] Found IPv6 ULA address, using it for blocking IPv6 ads
  [i] IPv4 address: 10.0.0.63/24
  [i] IPv6 address: fd2f:52eb:a83a:0:ba27:ebff:fe6d:895a
  [i] Web Interface On
  [i] Web Server On
  [i] Logging On.
  [i] Privacy level 0  [i] Performing reconfiguration, skipping download of local repos
  [βœ“] Resetting repository within /etc/.pihole...
  Unable to reset /var/www/html/admin, exiting installer

I’ll try an uninstall and reinstall and report back

You’ll need to sudo rm -rf /etc/.pihole , sudo rm -f /etc/pihole and then curl -sSL https://install.pi-hole.net | bash

Nah, no need to do that. Just sudo git clone https://github.com/pi-hole/AdminLTE /var/www/html/admin

Have you tried to run the uninstall script previously francisp? That will cause some issues if you try to reinstall after an uninstall.

Did not work

[i] Existing PHP installation detected : PHP version 7.0.33-0+deb9u3
  [βœ“] Disk space check
  [βœ“] Update local cache of available packages

  [βœ“] Checking apt-get for upgraded packages... up to date!

  [i] Installer Dependency checks...
  [βœ“] Checking for apt-utils
  [βœ“] Checking for dialog
  [βœ“] Checking for debconf
  [βœ“] Checking for dhcpcd5
  [βœ“] Checking for git
  [βœ“] Checking for iproute2
  [βœ“] Checking for whiptail

  [i] Using Cloudflare
  [i] Static IP already configured
  [i] Found IPv6 ULA address, using it for blocking IPv6 ads
  [i] IPv4 address: 10.0.0.63/24
  [i] IPv6 address: fd2f:52eb:a83a:0:ba27:ebff:fe6d:895a
  [i] Web Interface On
  [i] Web Server On
  [i] Logging On.
  [βœ—] Check for existing repository in /etc/.pihole
  [βœ“] Clone https://github.com/pi-hole/pi-hole.git into /etc/.pihole

  [βœ—] Check for existing repository in /var/www/html/admin
  [βœ“] Clone https://github.com/pi-hole/AdminLTE.git into /var/www/html/admin

  [i] Main Dependency checks...
  [βœ“] Checking for cron
  [βœ“] Checking for curl
  [βœ“] Checking for dnsutils
  [βœ“] Checking for iputils-ping
  [βœ“] Checking for lsof
  [βœ“] Checking for netcat
  [βœ“] Checking for psmisc
  [βœ“] Checking for sudo
  [βœ“] Checking for unzip
  [βœ“] Checking for wget
  [βœ“] Checking for idn2
  [βœ“] Checking for sqlite3
  [βœ“] Checking for libcap2-bin
  [βœ“] Checking for dns-root-data
  [βœ“] Checking for resolvconf
  [βœ“] Checking for libcap2
  [βœ“] Checking for lighttpd
  [βœ“] Checking for php7.0-common
  [βœ“] Checking for php7.0-cgi
  [βœ“] Checking for php7.0-sqlite3

  [βœ“] Enabling lighttpd service to start on reboot...

  [i] FTL Checks...

  [βœ“] Detected ARM-hf architecture (armv6 or lower) Using ARM binary
  [i] Checking for existing FTL binary...
  [βœ“] Downloading and Installing FTL
  [βœ“] Creating user 'pihole'
  [βœ“] Installing scripts from /etc/.pihole

  [i] Installing configs from /etc/.pihole...
  [i] Existing dnsmasq.conf found... it is not a Pi-hole file, leaving alone!
  [βœ“] Copying 01-pihole.conf to /etc/dnsmasq.d/01-pihole.conf

  [i] Installing blocking page...
  [βœ“] Creating directory for blocking page, and copying files
  [βœ—] Backing up index.lighttpd.html
      No default index.lighttpd.html file found... not backing up

  [βœ“] Installing sudoer file

  [βœ“] Installing latest Cron script

  [βœ“] Installing latest logrotate script
  [i] Backing up /etc/dnsmasq.conf to /etc/dnsmasq.conf.old

  [i] No active firewall detected.. skipping firewall configuration
  [βœ“] man pages installed and database updated
  [i] Testing if systemd-resolved is enabled
  [i] Systemd-resolved is not enabled
  [βœ“] Restarting lighttpd service...
  [βœ“] Enabling lighttpd service to start on reboot...
  [i] Restarting services...
  [βœ“] Enabling pihole-FTL service to start on reboot...
  [βœ“] Restarting pihole-FTL service...
  [βœ“] Deleting existing list cache
  [i] Pi-hole blocking is enabled
  [i] Neutrino emissions detected...
  [βœ“] Pulling blocklist source list into range

  [i] Target: raw.githubusercontent.com (hosts)
  [βœ“] Status: Retrieval successful

  [i] Target: mirror1.malwaredomains.com (justdomains)
  [βœ“] Status: Retrieval successful

  [i] Target: sysctl.org (hosts)
  [βœ“] Status: Retrieval successful

  [i] Target: zeustracker.abuse.ch (blocklist.php?download=domainblocklist)
  [βœ“] Status: Retrieval successful

  [i] Target: s3.amazonaws.com (simple_tracking.txt)
  [βœ“] Status: Retrieval successful

  [i] Target: s3.amazonaws.com (simple_ad.txt)
  [βœ“] Status: Retrieval successful

  [i] Target: hosts-file.net (ad_servers.txt)
  [βœ“] Status: Retrieval successful

  [βœ“] Consolidating blocklists
  [βœ“] Extracting domains from blocklists
  [i] Number of domains being pulled in by gravity: 138193
  [βœ“] Removing duplicate domains
  [i] Number of unique domains trapped in the Event Horizon: 115963
  [i] Nothing to whitelist!
  [i] Number of regex filters: 0
  [βœ“] Parsing domains into hosts format
  [βœ“] Cleaning up stray matter

  [βœ“] Force-reloading DNS service
  [βœ“] DNS service is running
  [i] Pi-hole blocking will be enabled
  [i] Enabling blocking
  [βœ“] Reloading DNS service
  [βœ“] Pi-hole Enabled
  [i] Web Interface password: 1OtXYdi-
  [i] This can be changed using 'pihole -a -p'

  [i] View the web interface at http://pi.hole/admin or http://10.0.0.63/admin

  [i] You may now configure your devices to use the Pi-hole as their DNS server
  [i] Pi-hole DNS (IPv4): 10.0.0.63
  [i] Pi-hole DNS (IPv6): fd2f:52eb:a83a:0:ba27:ebff:fe6d:895a
  [i] If you set a new IP address, please restart the server running the Pi-hole

  [i] The install log is located at: /etc/pihole/install.log
Installation Complete!

root@pimosquitto:~/Pi-hole/automated install# pihole -a -p
Enter New Password (Blank for no password):
Confirm Password:
[βœ“] New password set
root@pimosquitto:~/Pi-hole/automated install#

New debug token : https://tricorder.pi-hole.net/w093ezpa25

Yes I did uninstall before

There is a known bug with uninstall and reinstall.

sudo apt purge lighttpd
pihole -r

Thanks guys. This fixed it !!!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.