URL allestörungen

Servus,

ich habe folgendes Problem.
Seit ich Pi-Hole am laufen habe, wird bei mir die URL allestörungen.de nicht mehr aufgelöst.
Hat jemand eine Idee, wie ich das Problem lösen kann?

Funktioniert bei mir problemlos.
Hast du die URL in die Whitelist eingetragen?

1 Like

What is the output of this command from the Pi terminal:

pihole -q -adlist allestorungen.de

pi@raspberrypi:~ $ pihole -q -adlist allestorungen.de
[i] No results found for allestorungen.de within the block lists

Es sieht so aus, als könne der Pi das ö in der URL nicht auflösen. In der Blacklist ist nichts zu finden.

Okay… Ich musste die URL allestörungen.de in die Witheliste eintragen.

Wie gesagt, bei mir ging es auch ohne Eintrag in die Whitelist problemlos.
Da öüä und ein paar weitere Sonderzeichen (nicht nur deutsche) schon länger Teil der entsprechenden Spezifikationen sind, kann ich mir kaum vorstellen, dass das Problem am Pihole liegt
@jfb it is possible, that Pihole can’t handle special characters?

liegt vermutlich an regex/Wildcard blocking. Schaue mal nach ob da etwas mit “xn–” drin steht.

Bei mir habe ich

^(.+[-_.])??xn–

Mit Domain-Namen mit “xn–” sind Zwischenschritt um Domains mit Sonderzeichen aufzulösen.

https://de.wikipedia.org/wiki/Internationalisierter_Domainname

Wenn man den Abschnitt ASCII Spoofing durchliest versteht man warum es durchaus sinn macht alles mit xn-- zu blacklisten.

Jep, dass war es…

^(.+[-_.])??xn

Hatte ich auch in der regex.

Das ist bei mir nicht drin (gewesen). Blockt die Adresse trotz Whitelist-Eintrag. Ich habs wieder rausgenommen.
Mein Fhler: War nicht in der Whitelist.

Ich habe jetzt mein Probleme mehr.
Ich habe die Adresse einfach in die Whitelist gepackt und es läuft.

Witzigerweise will mein pihole die Adresse nicht in die Whitelist aufnehmen, weder über die Oberfläche noch über ssh mit pihole -w allestörungen.de
Ist die “hidden” noch irgendwo drin? Ich hatte sie mal eingetragen (s.o.), aber dann wieder gelöscht

Du musst diese Adresse in die Whitelist einfügen:

xn--allestrungen-9ib.de

Naja, Ja und Nein. Zumindest nicht in Ihrer “Reinform” als Umlaute, siehe

Der korrekte Ansatz ist

wenn Ihr diese Domain in Firefox o.Ä. einfügt, werdet Ihr sehen, dass sie Euch - obwohl genau so verarbeitet - mit Umlauten angezeigt wird.

Genau dies… Ich wäre da auch nicht drauf gekommen, hätte ich mir nicht das Log des Pi-Hole angesehen, in dem diese URL geblockt wurde.

Danke euch! Hat jetzt funktioniert. Wieder was gelernt :slight_smile:

Die Umwandlung wird in Zukunft für Euch automatisiert. :slight_smile:

2 Likes