Upgrade to Version 4 fails


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

pihole -up makes an complete update

Actual Behaviour:

Update fails for FTL
pi@red-node-hole:~ $ pihole -up
[i] Checking for updates…
[i] Pi-hole Core: up to date
[i] FTL: update available

[i] FTL out of date

[i] FTL Checks…
[i] Downloading and Installing FTL…curl: (22) The requested URL returned error: 404 Not Found
[✗] Downloading and Installing FTL
Error: URL not found

I have tried the various proposals in the forum, but none resolved my problems, e.g
pihole -r and afterwards pihole -up

Debug Token:

rk0px2mzvd


#2

Edit /etc/resolve.conf to reflect nameserver=8.8.8.8


#3

I have done that before and now again, but I get the same error as before


#4

The you have to wait till someone that can access your debug token had a look at your content.


#5

Thanks for the message, I will wait :slight_smile:


#7

Your debug log looks fine save for FTL being stuck at 3.0

I know you mentioned you had attempted the following but i do have to ask to try again with the following steps

Please try the following steps

  1. sudo nano /etc/resolv.conf
  2. edit 127.0.0.1 to 9.9.9.9
  3. save
  4. Re-run pihole -up

#8

Thanks for your reply.

  1. I did
    sudo nano /etc/resolv.conf

Resulted in:

Generated by resolvconf

nameserver 127.0.0.1

Edited it to:

Generated by resolvconf

nameserver 9.9.9.9

saved and run:
pihole -up

Result:
pi@red-node-hole:/ $ sudo pihole -up
[i] Checking for updates…
[i] Pi-hole Core: up to date
[i] FTL: update available

[i] FTL out of date

[i] FTL Checks…
[i] Downloading and Installing FTL…curl: (22) The requested URL returned error: 404 Not Found
[✗] Downloading and Installing FTL
Error: URL not found

Cecked again sudo nano /etc/resolv.conf`

Generated by resolvconf

nameserver 9.9.9.9

Unfortunately I did not solve the issue.
Any other ideas?


#9

This will be fixed in the next release.

Hope that someone can help you to install pihole.


#10

Run pihole -r after changing /etc/resolv.conf, and then pihole -up


#11

Thanks for supplying additional ideas.

I have done a reboot, changed nameserver to 9.9.9.9 and saved

run pihole -r option repair iption without problems

unfortunately pihole -up gave me the well known error:

[i] Checking for updates…
[i] Pi-hole Core: up to date
[i] FTL: update available

[i] FTL out of date

[i] FTL Checks…
[i] Downloading and Installing FTL…curl: (22) The requested URL returned error: 404 Not Found
[✗] Downloading and Installing FTL
Error: URL not found


#15

Thanks for your proposal, I did:

reboot
sudo nano /etc/resolv.conf`
changed 127.0.0.1 to 1.1.1.1
saved
pihole -up
result:
[i] Checking for updates…
[i] Pi-hole Core: up to date
[i] FTL: update available

[i] FTL out of date

[i] FTL Checks…
[i] Downloading and Installing FTL…curl: (22) The requested URL returned error: 404 Not Found
[✗] Downloading and Installing FTL
Error: URL not found

checked again:
sudo nano /etc/resolv.conf
nameserver 1.1.1.1

so it did not change and problem is still there


#16

Have a look at this: https://github.com/pi-hole/pi-hole/issues/2336

check if you have enough space fee to do the update

And don’t forget to use sudo pihole -up if you are not root. :wink:


#17

Hi again,
I checked that I have enough space.
I also looked at the proposed link and experimented with the provided information.
Actually it changed a bit, I now have in the admin information page:
Status

Active FTL offline
Load: 0.49 0.49 0.34
Memory usage: 20.7 %

before FTL was online

the graphs keep loading (of course) and the version information canged to

Pi-hole Version v4.0 Web Interface Version v4.0 FTL Version vDev (master, vDev-8493df4)

before it was FTL v3.X

the output of
~ $ cat /etc/pihole/ftlbranch
master

sudo pihole -r did not help, also changing again to another DNS server 9.9.9.9 or 8.8.8.8 etc did not help


#18

Please run a new debug log, upload it and post the token here. Thanks.


#20

This is the new debug Token:

ebcyaimy5h

Thanks


#22

run pihole checkout master and see if that will get FTL updated (might not, but worth the try).


#23

Thanks for your help

sudo pihole checkout master
Please note that changing branches severely alters your Pi-hole subsystems
Features that work on the master branch, may not on a development branch
This feature is NOT supported unless a Pi-hole developer explicitly asks!
Have you read and understood this? [y/N] y

[i] Shortcut “master” detected - checking out master branches…
[i] Pi-hole core
[✓] Switching to branch: ‘master’ from ‘refs/heads/master’
Bereits aktuell.

[i] Web interface
[✓] Switching to branch: ‘master’ from ‘refs/heads/master’
Bereits aktuell.

[✓] Detected ARM-hf architecture (armv6 or lower) Using ARM binary
[✓] Installing FTL

since it did not show any changes, I did a reboot

Still it gives exactly the same picture as before

Just in case a new debug token: ily9btpe85


#26

You missed it:

[✓] Detected ARM-hf architecture (armv6 or lower) Using ARM binary
[✓] Installing FTL

You can do a pihole -r to check if all is correctly installed.


#27

For compatibility reasons, you should change your locale to en_US.UTF-8 from your de_DE.UTF-8 via sudo raspi-config

Once locale has been changed, run a pihole -up.

Let us know if you experience the same error after the locale change.


#28

This is the output of pihole -r:

[i] Existing PHP installation detected : PHP version 7.0.27-0+deb9u1
[i] Repair option selected
[✓] Disk space check

[✓] Update local cache of available packages

[✓] Checking apt-get for upgraded packages… 6 updates available
[i] It is recommended to update your OS after installing the Pi-hole!

[i] Installer Dependency checks…
[✓] Checking for apt-utils
[✓] Checking for dialog
[✓] Checking for debconf
[✓] Checking for dhcpcd5
[✓] Checking for git
[✓] Checking for iproute2
[✓] Checking for whiptail

[i] Performing reconfiguration, skipping download of local repos
[✓] Resetting repository within /etc/.pihole…
[✓] Resetting repository within /var/www/html/admin…
[i] Main Dependency checks…
[✓] Checking for bc
[✓] Checking for cron
[✓] Checking for curl
[✓] Checking for dnsutils
[✓] Checking for iputils-ping
[✓] Checking for lsof
[✓] Checking for netcat
[✓] Checking for psmisc
[✓] Checking for sudo
[✓] Checking for unzip
[✓] Checking for wget
[✓] Checking for idn2
[✓] Checking for sqlite3
[✓] Checking for libcap2-bin
[i] Checking for dns-root-data (will be installed)
[i] Checking for resolvconf (will be installed)
[✓] Checking for lighttpd
[✓] Checking for php7.0-common
[✓] Checking for php7.0-cgi
[✓] Checking for php7.0-sqlite3

But the admin page still shows
Status

Active FTL offline
Load: 0.3 0.19 0.12
Memory usage: 24.7 %

Graphs continue loading

and version info at the buttom shows:
Pi-hole Version v4.0 Web Interface Version v4.0 FTL Version vDev (master, vDev-8493df4)