updating troubles


#1

[✓] Your debug token is: ef2gpppbg2

root@pihole:~# sudo pihole -up
[i] Checking for updates…
[i] Pi-hole Core: up to date
[i] FTL: update available

[i] FTL out of date

[i] FTL Checks…

[i] Downloading and Installing FTL…curl: (22) The requested URL returned error: 404 Not Found
[✗] Downloading and Installing FTL
Error: URL https://github.com/pi-hole/FTL/releases/download/v4.1.2/ not found


#2

Please try the following steps

  1. sudo nano /etc/resolv.conf
  2. edit 127.0.0.1 to 9.9.9.9 or your preferred third party DNS service
  3. save
  4. Re-run pihole -up

#3

i put
nameserver 9.9.9.9

instead of the defautl one but no luck. still same error

by the way i got 404 in my browser if i try to reach: https://github.com/pi-hole/FTL/releases/download/v4.1.2/


#4

what OS is this on? the FTL download should directly grab one of the packages based on your architechture


#5

uname -a

Linux pihole 4.4.127-mainline-rev1 #1 SMP Sun Apr 8 10:33:17 UTC 2018 armv7l armv7l armv7l GNU/Linux


#9

still same trouble…

really strange.

sudo pihole -up
[i] Checking for updates…
[i] Pi-hole Core: up to date
[i] FTL: update available

[i] FTL out of date

[i] FTL Checks…

[i] Downloading and Installing FTL…curl: (22) The requested URL returned error: 404 Not Found
[✗] Downloading and Installing FTL
Error: URL https://github.com/pi-hole/FTL/releases/download/v4.1.2/ not found


#10

What versions are you all currently on? pihole -v?


#11

Pi-hole version is v4.1.1 (Latest: v4.1.1)
AdminLTE version is v4.1.1 (Latest: v4.1.1)
FTL version is v3.0 (Latest: v4.1.2)


#12

Try manually installing the new FTL version:

sudo service pihole-FTL stop
sudo wget https://ftl.pi-hole.net/v4.1.2/pihole-FTL-arm-linux-gnueabihf -O /usr/bin/pihole-FTL
sudo service pihole-FTL start

#13

thanks.
it worked

root@pihole:~# sudo service pihole-FTL stop
root@pihole:~# sudo wget https://ftl.pi-hole.net/v4.1.2/pihole-FTL-arm-linux-gnueabihf -O /usr/bin/pihole-FTL
–2019-01-16 16:26:12-- https://ftl.pi-hole.net/v4.1.2/pihole-FTL-arm-linux-gnueabihf
Resolving ftl.pi-hole.net (ftl.pi-hole.net)… 139.59.170.52
Connecting to ftl.pi-hole.net (ftl.pi-hole.net)|139.59.170.52|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 3407856 (3.2M) [application/octet-stream]
Saving to: ‘/usr/bin/pihole-FTL’

/usr/bin/pihole-FTL 100%[===================>] 3.25M 6.70MB/s in 0.5s

2019-01-16 16:26:12 (6.70 MB/s) - ‘/usr/bin/pihole-FTL’ saved [3407856/3407856]

root@pihole:~# sudo service pihole-FTL start
root@pihole:~# pihole -v
Pi-hole version is v4.1.1 (Latest: v4.1.1)
AdminLTE version is v4.1.1 (Latest: v4.1.1)
FTL version is v4.1.2 (Latest: v4.1.2)
root@pihole:~# sudo pihole -up
[i] Checking for updates…
[i] Pi-hole Core: up to date
[i] FTL: up to date
[i] Web Interface: up to date

[✓] Everything is up to date!


#14

Unfortunately after few minutes FTL stopped



Status
Active FTL offline
Load:  0.1  0.06  0.01
Memory usage:  4.5 %

trying rebooting entire server :-/

no luck

FTL down.
dns seems working but dashboard not.

how can i fix ?


#15

[✓] Your debug token is: kcfvfdcg7z


#16

You have dnsmasq running and taking up port 53. FTLDNS embeds its own version of dnsmasq, so you can stop and remove the other dnsmasq.


#17

please any link or tutorial about this change ?

i would like to get everything working also after a reboot of course…


#18

done

root@pihole:~# sudo  systemctl stop dnsmasq
root@pihole:~# sudo systemctl disable dnsmasq
root@pihole:~# sudo service pihole-FTL start

but i’m unsure about what will happen at next reboot…

dashboard now works


#19

It‘s announced here: https://pi-hole.net/2018/08/06/pi-hole-v4-0-released-with-ftldns-improved-blocking-modes-regex-docker-and-more/

The long awaited version v4.0 of Pi-hole’s FTL daemon is available! It ships with a built-in DNS server (based on a private fork of dnsmasq ) to provide you with the best performance. Due to the inclusion of the DNS server, you will see the daemon also being referred to as FTL DNS.

Source: https://github.com/pi-hole/FTL/releases/tag/v4.0


#20

Ok has been announced but what’s not so good is that the upgrade does not worked.

At least for me of course. ( from 3.1 )

best regards


closed #21

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.