Updated to v3.3; web UI thinks CORE still at v3.2.1


I'm setting up a fresh Debian install in a VM to see what results I get.

More to come.

Just additional info here...

All I did to update was what I've been doing since day one: pihole -up

I'd let you know if I was doing something special here.

Can't think of anything that I'm doing out of the ordinary.

1 Like

Yeah, it's a backend problem--nothing you did. We're still trying to figure it out

Ok, cool.

Let me know if there's anything I can do to help!

Try cd /etc/.pihole && sudo git fetch --tags and see if that pulls the latest updates and retags the current hash.

1 Like

Worky worky!


pihole version
Pi-hole version is v3.3 (Latest: v3.3)
AdminLTE version is v3.3 (Latest: v3.3)
FTL version is v3.0 (Latest: v3.0)

If this is not correct etiquette, then please accept my apologies. And delete or move or I can move. But seems I ran into same issue.

Oddly for just "silly experimenting" on this boredom days of course lol. I thought long ago I'd setup 2 pihole servers to just act as a primary dns and secondary and I understand the term "primary/secondary" is little misunderstood among the greater populace. But my secondary pi-hole dns server was just added to a little mini virtual machine on a box I run 8 virtual machines as minute part of my homelab.

But I most definitely had to stick to the Pi-Hole roots so while I admit I didn't install pihole on the newer 3rd generation version of the Raspberry Pi, I did break out my old Raspberry Pi B model. I use a Cisco SLM-2008 smart switch, physical cases I got 6, with 4 rackmount which I play around with type 1 hypervisors/ Freenas / openvpn/ a dedicated kodi box I built for television, but augmented it with a little minidlna server. And I'm always just goofing around with random things. I even go oldschool and break out my old cisco 2500 series router that is now so obsolete but never could trash it since it's what got me my little ccna cert before they branched out the certs a lot. But that's not important to story or question.

And with the above said I agree, admit I'm definitely about to likely make some chuckle as I place my size 15 shoe in my mouth . haha

As the original poster had posted I also ran into a similar situation today. I most the time check things from a Samsung tablet but even in firefox the samsung tablet never shows the message about upgrades available for some odd reason. But I once a week just manually update blocklists out of boredom.

So today I grabbed old pc case in closet and began building my son whose 21st birthday arrives in 4 days. And I've got everything ready, except he doesn't know it but he's going to build his own pc by his hands, with me over his shoulder and laid back unless its a bad idea that could pop something.

Now to freaking point and my apologies for context... So I'm in my server room, sit down to main pc/gaming pc my win7 pc noticed both primary and secondary pihole servers show upgrades needed for everything.

So the primary being raspberry pi model B running Raspbian fully updated.

copy/paste from /etc/os-release on primary dns server on Raspberry:
Raspbian/GNU/Linux 8 (jessie)
NAME="Rasbian/GNU/Linux 8"
Version="8 (Jessie)"

The pihole web interface at bottom had a message:
Pi-hole Version v3.2.1 (Update available!) Web Interface Version v3.3 FTL Version v3.0

So I've normally just ran [pihole -up] or [sudo pihole -up] both work just fine

So to verify it did upgrade, I ran command:

pi@pihole:/etc $ pihole -v
** Pi-hole version is v3.2.1-73-g1e87850 (Latest: v3.3)**
** AdminLTE version is v3.3 (Latest: v3.3)**
** FTL version is v3.0 (Latest: v3.0)**

so pihole -v to check version shows even though upgrade shows all successful it still lists it's just 3.2.1-73-g1e87850

And of course clearing cache in browser, and flushing dns which shouldnt matter, but for devils advocate of course. I then let pihole on the PI refresh it's blocklists once done I flushed all the logs and rebooted the Raspberry pi. Loaded the web /admin interface. It still shows at bottom that it's running 3.2.1 yet the other systems did upgrade. I logged back into Pi and issued pihole -up and it says

Checking for updates...
for all 3 systems and each system returns "up to date", I went to my tablet, went to old rooted phone I gutted the cell crap out of it turning it into a wifi only device which I use as my remote control around the house, since I run the kodi remote/roku remote/ remote my other pc's which I configured for some cool open source programs. Makes an old mobile used as a remote only easy peasy. But I see same as all the above on a windows 10 pro "kiosk" in living room entrance way I setup for couple neighbors 1 which he's legally blinde but they want him to fill all his disability and medical paperwork online so empathy got better of me and i setup a little all in one lenovo for that purpose or if I have guests that wanna goof on, can easily roll back a snapshot and keeps the curious from wanting in my server room to play with racks lol.

Ok I thought it'd clear up eventually...

Second case.

I have been running Pihole on a virtual machine debian server no gui's here. Alongside other benign little servers. I noticed it had upgrade available for all 3 packages of Pihole.
I ssh in from tablet and run sudo pihole -up.
It successfully upgrades and it reloads the blocklists and all starts up perfectly. I go to it's interface and uh oh.... same error or same message "Pi-Hole version 3.2.1 (current 3.3)"
so the meme image of Charlie Chan's hands with hand on head could have looked exactly like me at this point. This isn't a raspberry pi on my secondary dns pihole server ran inside a dedicated virtual machine on barebones debian server. I did every single step I mentioned doing to the Raspberry Pi version and got exact same issues. Pihole says it upgraded, I ran pihole repair and found no errors or saw none.

only issue i see that both mentioned was a lighthttp file to be backed up didnt exist but it gave no error at that.

Again cleared cache, used samsung tab A 9.7" android tablet, tested with a lenovo m73 maxed out win10 pro (my only win10 box), tested on my original fileserver a linux mint 18.3 AMD quad core pc same message in the web front end at bottom of page.

Used chrome which I never ever used on linux plus my tried and true firefox both show upgraded needed at bottom that 3.3 is available but im running 3.2.1 but when I type pihole -v on both the primary dns server ip running on a real raspberry shows it's running 3.3 and all up to date. Testing seconday pihole on a debian dedicated virtual machine I get exact same results pihole -v shows v3.3 installed and the other systems running latest. But the webpage for both primary dns and secondary dns scroll to bottom shows

Pi-hole Version v3.2.1 (Update available!) Web Interface Version v3.3 FTL Version v3.0

My humblest apologies for such a long post. This is definitely not a rant. I find Pi-hole absolutely genius. I've used dnsmasq for tinier similar situations but nothing ever like this how it all works hand in hand with blocklists. So major kudos to the creator/admin the development team, volunteers, the multitude of users to push such an awesome project to the forefront and I would not be surprised if Pi-Hole is a large driver behind helping push sales of such devices. So once again kudos.

Other than the web interface giving me wrong version info, I am not having any other issues, and all things still are blocked... random things get through but I run noscript, ublock origin, and privacy badger for those things that slip through, but it's caught so many things my firefox memory footprint stays on average lower than before I began using it. Especially keeping it as a primary and seconday since I do have quite a large homelab, then half my servers use primary/seconday pihole ip's in that order while rest flip it using seconday/primary in that order even though yes I know primary and secondary doesn't quite work like that but its just a lot of fun.

Does anyone have any suggestions I could try? I've cleared caches everywhere. I even used my gaming pc and erases the places.sqlite on top of all cache/cookies/etc up to restarting new profile and reloading my plugins.

Now I'll try to toss debug log tokens to see if anything may stand out that I'm blatantly missing which I would not be surprised at all if I have.

Primary Pi-Hole dns server:
Running on it's own dedicated Raspberry Pi Model B+
Debug Log: b7tcjn1jap

Seconday Pi-Hole dns server:
Running in a dedicated virtual machine debian server
Debug Log: g4unbhpffg

I'm in not anxious hurry, it's just after 8pm est my time so I'll peek in and out, but no big hurry, even though web interface shows incorrect on my home systems that is, even testing IE/Edge on my 1 win10 box, Chrome and Firefox on linux, and Firefox in win7 gaming pc and my android tablet all show the version 3.2.1 and upgrade available. Ran pihole -up it gave successfull for all systems involved with pihole rebooted both the raspberry pi and rebooted the virtual machine and cleared cache still the web interface shows the previous version but on command line for both Raspberry and Debian running pihole -v lists that it is 3.3

So I would like to humbly request any advice from this great community. I wanted to post cause i keep second guessing like should i have unstalled and reinstalled fresh, or flush logs/flush everything prior to upgrade. Yes i did the upgrade with and without using sudo even though both accounts had sudo access and never got error regarding permissions.

Thank you for your time, and my apologize if I should have started my own thread, if that's the case if a mod could split the topic maybe? I'd be much obliged.

Thank you, I'll check back later, again not in a rush or hurry, all works just perfectly as before no problems at all as far as dns functions go. So I'm still very happy and always very impressed at how something so simple is yet so amazingly powerful.

Thank you,
Eric, aka "Cito"

cd /etc/.pihole && git fetch --tags will clear up your version issues.

1 Like

jacob.salmela: Thank you very very much sir. Kudos, Same command worked on both my primary raspberry pi pihole server, and my little dedicated debian virtual machine pihole used as secondary dns server.

Both web interfaces for my primary pihole server and secondary now show:
Pi-hole Version v3.3 Web Interface Version v3.3 FTL Version v3.0

Again, thank you very much. I love the wonderful community this project has. Anyone perusing the help forums, I recommend donating to these guys. Great product, low resources, works great, especially combined with your favorite browser extensions, and the support is amazing.

Thank you again, and have a wonderful evening!

1 Like

Updated three Pi-holes today. One went fine, the other two required "git fetch --tags" for the updated version to properly display.

Hello all,

I am having a similar issue as above after running pihole -up. My pihole -v shows:

    Pi-hole version is v3.2.1 (Latest: v3.3)
      AdminLTE version is v3.3 (Latest: v3.3)
      FTL version is v3.0 (Latest: v3.0)

When I did cd /etc/.pihole && git fetch --tags the version in the web interface changed to " vDev (HEAD, v3.2.1-0-ge602008)". Now when I run pihole -up I get the error:

fatal: HEAD does not point to a branch

      Error: Remote revision could not be obtained, please contact Pi-hole Support
      Additional debugging output:
    HEAD detached at e602008
    nothing to commit, working tree clean

My debug token is: 5v13jqqx80



cd /etc/.pihole && sudo git checkout master

Boom that fixed the version in pihole -v:

Pi-hole version is v3.3 (Latest: v3.3)
  AdminLTE version is v3.3 (Latest: v3.3)
  FTL version is v3.0 (Latest: v3.0)

but the footer in the web interface is still reads:

"Pi-hole Version vDev (HEAD, v3.2.1-0-ge602008) Web Interface Version v3.3 FTL Version v3.0 (Update available!)"

I restarted lighttdp and same issue. I cleared browser cache to verify.

EDIT: The browser issue resolved itself. Not sure what I did, but you can consider the issue resolved. Thank you!

Ok apologies, a new problem has cropped up. Now the web interface is not counting dns queries and the line graph has flat-lined. I tried pihole logging on which stated logging was enabled.

To be clear, the pihole is still blocking ads, it's just not showing in the web interface. Should I open a new ticket? Debug token is efe5vtb3th

I've tried running the command to correct the version number, but I'm getting an error:

pi@raspberrypi:/etc/.pihole $ cd /etc/.pihole && git fetch --tags
error: cannot open .git/FETCH_HEAD: Permission denied

I'm on the stretch version of Raspian:

PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION="9 (stretch)"

Also tried Dan's suggestion, but I'm already on master:

pi@raspberrypi:/etc/.pihole $ cd /etc/.pihole && sudo git checkout master
Already on 'master'

Pi-hole is up to date:

pi@raspberrypi:/etc/.pihole $ pihole -up
  [i] Checking for updates...
  [i] Pi-hole Core:     up to date
  [i] FTL:              up to date
  [i] Web Interface:    up to date

  [✓] Everything is up to date!
pi@raspberrypi:/ $ pihole -v
  Pi-hole version is v3.2.1-73-g1e87850 (Latest: v3.3)
  AdminLTE version is v3.3 (Latest: v3.3)
  FTL version is v3.0 (Latest: v3.0)

Any ideas?

cd /etc/.pihole
sudo git fetch --tags

Thanks Dan, that did the trick. I thought I had already tried that but apparently not.

I have the same problem, but
cd /etc/.pihole
sudo git fetch --tags

did not help, even after reboot - still shows Pi-hole Version v3.2.1 (Update available!)

Ok, now I did run the update once more and this time it seems to be correct - case closed.