Updated to v3.3; web UI thinks CORE still at v3.2.1

v3-3

#8

Okay, let’s look at the tags your install knows about.

cd /etc/.pihole
sudo git fetch
sudo git tag

#9

For brevity…


v3.2
v3.2.1
v3.3


#10

You have the current tags, try:

cd /etc/.pihole
git checkout tags/v3.3

And then if that works, run pihole -r to make sure everything is good.


#11

One thing I first checked was what code in the admin web UI was checking the local version.

I found cd /etc/.pihole/ && git describe --long --tags, ran that and got…

v3.2.1-73-g1e87850


#12

Are you running any outside modifications like the dark theme or the speedtest addon?


#13

Negatory.

The only modification I’ve done is what’s described here.


#14

Got the following when I checked out tags/v3.3…

Note: checking out ‘tags/v3.3’.

You are in ‘detached HEAD’ state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by performing another checkout.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -b with the checkout command again. Example:

git checkout -b new_branch_name

HEAD is now at e602008… Merge pull request #1856 from pi-hole/release/v3.2.1


#15

Try the pihole -r now to balance everything.


#16

Checked out tags/v3.3, ran pihole -r, Repaired.

pihole version
Pi-hole version is v3.2.1 (Latest: v3.3)
AdminLTE version is v3.3 (Latest: v3.3)
FTL version is v3.0 (Latest: v3.0)


#17

Try pihole checkout master and we’ll see if that kicks things over.


#18

The commit hash that you posted is the v3.3 hash, so you are running version 3.3, but for some reason you are getting a version mismatch. The tags haven’t mapped to the release hash. Will take a look at this further.


#19

Yeah, literally just did that.

Same result. :slight_smile:

Diff between doing pihole -r after checking out tags/v3.3 versus off of master appears to be this (at the commit level)…

tags/v3.3

  • Pi-hole version is v3.2.1 (Latest: v3.3)

master

  • Pi-hole version is v3.2.1-73-g1e87850 (Latest: v3.3)

#20

That is v3.3, if you go to our Github page you’ll see that 1e87850 as the version 3.3 latest release.


Update to 3.3 is not succsesfull
#21

Gotcha.

I’m setting up a fresh Debian install in a VM to see what results I get.

More to come.


#22

Just additional info here…

All I did to update was what I’ve been doing since day one: pihole -up

I’d let you know if I was doing something special here.

Can’t think of anything that I’m doing out of the ordinary.


#23

Yeah, it’s a backend problem–nothing you did. We’re still trying to figure it out


#24

Ok, cool.

Let me know if there’s anything I can do to help!


#25

Try cd /etc/.pihole && sudo git fetch --tags and see if that pulls the latest updates and retags the current hash.


[SOLVED] Pihole fails to upgrade
#26

Worky worky!

36%20PM

pihole version
Pi-hole version is v3.3 (Latest: v3.3)
AdminLTE version is v3.3 (Latest: v3.3)
FTL version is v3.0 (Latest: v3.0)


#27