Update to FTL-5.9 failed due to apt errors

Hello everyone, first time I've been here so bear with me.... I have problems updating our two pi's to the latest FTL-5.9.
I am at 5.8.1 and did pihole -up, the last message was
[✗] Update local cache of available packages
Error: Unable to update package cache. Please try "sudo apt-get update"
Unable to complete update, please contact Pi-hole Support

So I tried the sudo apt-get update, this changed nothing, error and version stayed the same:
Pi-hole version is v5.4 (Latest: v5.4)
AdminLTE version is v5.6 (Latest: v5.6)
FTL version is v5.8.1 (Latest: v5.9)

So, being a total nerd when it comes to linux/unix and whatnot, I have no clue how to get to the latest version except completely reinstalling it, but this should not be an option at all, given the fact that my 2nd pi is elsewhere and remotely did the same thing with the same result.

Does anyone has a solution or something I can try?

Did you try pihole -up again after running sudo apt-get update ?

yup, tried this a few times, same result....

Please post the output of

sudo apt update

I tried your solution too, it came with this response:

pi@pi-hole-ellen:~ $ sudo apt-get update --allow-releaseinfo-change
Geraakt:1 http://archive.raspberrypi.org/debian buster InRelease
Ophalen:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15,0 kB]
Ophalen:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13,0 MB]
13,0 MB opgehaald in 25s (522 kB/s)
Pakketlijsten worden ingelezen... Klaar
N: Bij pakketbron 'http://raspbian.raspberrypi.org/raspbian buster InRelease' is de 'Suite'-waarde gewijzigd van 'stable' naar 'oldstable'
pi@pi-hole-ellen:~ $ pihole -v
  Pi-hole version is v5.4 (Latest: v5.4)
  AdminLTE version is v5.6 (Latest: v5.6)
  FTL version is v5.8.1 (Latest: v5.9)
pi@pi-hole-ellen:~ $

So, the FTL is still 5.8.1..
Now I did a pihole -up....

After a while and a lot of responses, it said:

Update Complete!

  Current Pi-hole version is v5.4
  Current AdminLTE version is v5.6
  Current FTL version is v5.9
pi@pi-hole-ellen:~ $

So thanks for helping the nerd in me out!

1 Like

Do you still get this error when running the apt-get update? I just want to rule out that your system is somehow broken and you'll experience this again with the next update.

I am still having an error with the FTL-5.9 update.
Here's my output:

pi@raspberrypi:~ $ pihole -v
  Pi-hole version is v5.4 (Latest: v5.4)
  AdminLTE version is v5.6 (Latest: v5.6)
  FTL version is v5.8.1 (Latest: v5.9)
pi@raspberrypi:~ $ pihole -up
  [i] Checking for updates...
  [i] Pi-hole Core:     up to date
  [i] Web Interface:    up to date
  [i] FTL:              update available

  [i] FTL out of date, it will be updated by the installer.

  [✓] Root user check

        .;;,.
        .ccccc:,.
         :cccclll:.      ..,,
          :ccccclll.   ;ooodc
           'ccll:;ll .oooodc
             .;cll.;;looo:.
                 .. ','.
                .',,,,,,'.
              .',,,,,,,,,,.
            .',,,,,,,,,,,,....
          ....''',,,,,,,'.......
        .........  ....  .........
        ..........      ..........
        ..........      ..........
        .........  ....  .........
          ........,,,,,,,'......
            ....',,,,,,,,,,,,.
               .',,,,,,,,,'.
                .',,,,,,'.
                  ..'''.

  [✗] Update local cache of available packages
  Error: Unable to update package cache. Please try "sudo apt-get update"
  Unable to complete update, please contact Pi-hole Support
pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Reading package lists... Done
E: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
pi@raspberrypi:~ $

sorry for not knowing what to do next.
I can read that it says to accept something, but I do not know where to do that.

sudo apt-get update --allow-releaseinfo-change

That's what i was looking for.
It worked. Thank you.

I just did another update after that, pihole -up and that cleared the sky for me...

FWIW, I also had the same issue, but after running the

sudo apt-get update --allow-releaseinfo-change

it appears to have worked, but I never really saw the update complete. But when I do pihole -v, it shows that FTL is now 5.9.

Thanks for your posts, a great resource.