Update problems

Not really sure what to do other than this after outputting the debug of my pi-hole. I have pasted the link below.

My issue is that when I try and run pihole -up it fails with an unsupported OS error, so I, at the instruction of the error message ran PIHOLE_SKIP_OS_CHECK=true sudo -E pihole -r this then fails with Unable to locate package php5-xml. I have, also per a forum suggestion, removed the folder and contents located at /var/www/html/admin and redownloaded the AdminLTE branch from GitHub. I then reran the skip os part and it still fails with install PHP 5. so I tried to run sudo apt-get php5-xml, package not found. So then I tried sudo pip install php5-xml, pip command not found. I am kinda stuck and out of ideas, can anyone help?

https://tricorder.pi-hole.net/fxfbsumx1b

You are running an unsupported OS. This OS is well past long term support and EOL with Debian/Raspbian, and has not been supported by Pi-hole for several years.

I recommend that you update this OS to either Stretch or Buster, both of which are supported by Pi-hole. Buster would be preferable from a Debian standpoint, as it is currently in regular support.

You can do an in-place upgrade, but I would make a backup first. I have done three in place from Stretch to Buster with no issues - you may have different results.

*** [ DIAGNOSING ]: Operating system
[✓] Raspbian GNU/Linux 8 (jessie)

In addition to Jessie being ancient at this point, you're on two different releases of Pi-hole. Front end v5 but your FTL is still v4.

*** [ DIAGNOSING ]: Core version
[i] Core: v5.1.2 (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)
[i] Branch: master
[i] Commit: v5.1.2-0-g6b536b7

*** [ DIAGNOSING ]: Web version
[i] Web: v5.1.1 (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)
[i] Branch: master
[i] Commit: v5.1.1-0-ga03d1bd

*** [ DIAGNOSING ]: FTL version
[✓] FTL: v4.3.1 (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)

Best option, nuke it and start fresh.