Unable to whitelist domain that is on blocklist

whitelisting
#1

Unable to whitelist via CLI

Expected Behaviour:

When I add a domain using pihole -w (domain) the domain should be added to the white list.

Fixed I manually went to /etc/pihole/whitelist.txt and removed the domain. I then repeated pihole -w (domain) and pihole restartdns and it appears to be added correctly and correctly allowed to load.

Actual Behaviour:

  • When I run pihole -q (domain) I am told it is on a blocklist.

  • When I run pihole -w (domain) I am told it is not, and cannot be added to the whitelist.

  • The domain is blocked and I have no way of unblocking it without removing the entire block list that includes it.

  • In case it matters the domain is prod.imgur.map.fastlylb.net. It is used by mobile reddit pretty heavily.

  • Also I seem to be experiencing this issue with the same domain when using the Admin console: URL in whitelist is still blocked

Debug Token:

7ejlkqsms8

0 Likes

#2

Try this:
In the web Admin pages visit the whitelist and remove the URL that you’ve tried to whitelist.
Then, in the console, run pihole -w with your URL again.

I found that the console method doesn’t work if you’ve already tried a web based method, including the Pihole admin pages or the white list link (that used to be?) included with a “blocked” message page.

The error message in this case (trying to whitelist a page that Pihole thinks is already whitelisted) is a little cryptic (“Not found on any blacklist” or something similar). Hopefully this addresses your issue.

0 Likes

#3
0 Likes

closed #4

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes