Unable to update web interface to 3.0.1

Web version is not updating for me

Admin panel

something is wrong, I have restarted my vps, and is the same.

I also can't get the update,, I tried

sudo git reset --hard


sudo pihole checkout master

@elaur @deathbybandaid were either of you on different branches at some point before updating?

ge204cea is in fact the correct commit to be on, but the version isn't reporting correctly . Try:

cd /var/www/html/admin
sudo git fetch --tags

I keep my main pi on the master branch,,,, the wife doesn't like when the internet is being funny,,,,

remote: Counting objects: 118, done.
remote: Compressing objects: 100% (43/43), done.
remote: Total 118 (delta 82), reused 107 (delta 71), pack-reused 0
Receiving objects: 100% (118/118), 84.33 KiB | 0 bytes/s, done.
Resolving deltas: 100% (82/82), completed with 41 local objects.
From https://github.com/pi-hole/AdminLTE
 * [new tag]         1.2.1-bower -> 1.2.1-bower
 * [new tag]         1.3.0      -> 1.3.0
 * [new tag]         1.3.1      -> 1.3.1
 * [new tag]         v1.2.1     -> v1.2.1
 - [tag update]      v3.0.1     -> v3.0.1

Edit: that seems to have done the trick

1 Like

I tried it on a new install and it seemed to fetch the tag version correctly, but when I updated my home install it did the same as you both described.

That said, mine is always on different branches. My wife is quite forgiving when things go wrong :smiley:


I do have a cronjob to run pihole -up every half-hour, so that I should theoretically always be on the newest release.

I don't know if that would make a difference, but it shouldn't

Keen! We don't release that often :wink:

Looks like this issue will be seen across the board, as it seems to be with a pre-existing v.3.0.1 (from the original AdminLTE repo) tag that we deleted the other day.

Can you run a pihole -up now? Should show version 3.0.1a No don't. It wont show that.

I was just about to say that it didn't work lol

Side Note: I live in EST, have a 8-5 IT position,,, and most days don't actually do a whole lot.

If you guys ever need anybody to do some testing,,,,

I have the time


I'm a very new user. My install is less than 24 hours ago.

I was prompted with the update in the admin panel. I ran a pihole -up and now I get a Pi-hole Version v3.0.1 Web Interface Version v3.0.1 FTL Version v2.6.

It now asks for a password as advertised. Great job. Thanks!

1 Like