Unable to update or repair FTL to 4.2.3

#1

Expected Behaviour:

FTL 4.2.3 should download and install during the update or repair process (pihole -up and -r)

Actual Behaviour:

After “Downloading and installing FTL” for what feels like at least 10 minutes, the following appears:

  [i] Downloading and Installing FTL...curl: (56) SSL read:curl: (56) SSL read: error:00000000:lib(0):func(0):reason(0), errno 104
  [✗] Downloading and Installing FTL
  Error: URL https://github.com/pi-hole/FTL/releases/download/v4.2.3/pihole-FTL-arm-linux-gnueabihf not found
  [✗] FTL Engine not installed

Debug Token:

https://tricorder.pi-hole.net/q52urppg76!

I have already tried changing the resolv.conf IP to a standard one, with no luck, and changed it back, and have run sudo apt-get update and sudo apt-get upgrade. Neither of them seems to have fixed this issue.

0 Likes

#2

Error 104 looks like it’s a connection reset by peer, which would be a problem with Github and their servers.

Can you run curl -o /tmp/pihole-FTL https://github.com/pi-hole/FTL/releases/download/v4.2.3/pihole-FTL-arm-linux-gnueabihf to completion?

0 Likes

#3

That command seems to work fine

pi@raspberrypi:~ $  curl -o /tmp/pihole-FTL https://github.com/pi-hole/FTL/releases/download/v4.2.3/pihole-FTL-arm-linux-gnueabihf
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   620    0   620    0     0    568      0 --:--:--  0:00:01 --:--:--   568
0 Likes

#4

Okay, you can just run sudo mv /tmp/pihole-FTL /usr/bin/ and then sudo service pihole-FTL restart. Everything should be up to date at that point.

1 Like

#5

After doing that, it seems the Pihole is no longer able to connect to the API

Upon running pihole -r, I get the following:

  [✗] Downloading and Installing FTL
  Error: Unable to get latest release location from GitHub
  [✗] FTL Engine not installed

I ran pihole -d again, but wasn’t able to upload the debug log from within the function

EDIT: I was able to upload it after changing the resolv.conf IP again:

https://tricorder.pi-hole.net/ovuwro2zin!

0 Likes

#6

What is the output from sudo getcap /usr/bin/pihole-FTL and ls -la /usr/bin/pihole-FTL?

0 Likes

#7

Here’s what I got:

pi@raspberrypi:~ $ sudo getcap /usr/bin/pihole-FTL
pi@raspberrypi:~ $ ls -la /usr/bin/pihole-FTL
-rw-r--r-- 1 pi pi 620 Mar 24 23:28 /usr/bin/pihole-FTL
0 Likes

#8

Alright, run the below:

sudo chmod 755 /usr/bin/pihole-FTL
sudo chown root:root /usr/bin/pihole-FTL
sudo service pihole-FTL start

After that check with sudo systemctl status pihole-FTL

1 Like

#9

Here’s the output:

pi@raspberrypi:~ $ sudo chmod 755 /usr/bin/pihole-FTL
pi@raspberrypi:~ $ sudo chown root:root /usr/bin/pihole-FTL
pi@raspberrypi:~ $ sudo service pihole-FTL start
pi@raspberrypi:~ $ systemctl status pihole-FTL
● pihole-FTL.service - LSB: pihole-FTL daemon
   Loaded: loaded (/etc/init.d/pihole-FTL; generated; vendor preset: enabled)
   Active: active (exited) since Sun 2019-03-24 23:51:48 IST; 35s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 323 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/pihole-FTL.service

    Mar 24 23:51:36 raspberrypi systemd[1]: Starting LSB: pihole-FTL daemon...
    Mar 24 23:51:36 raspberrypi pihole-FTL[323]: Not running
    Mar 24 23:51:48 raspberrypi su[878]: Successful su for pihole by root
    Mar 24 23:51:48 raspberrypi su[878]: + ??? root:pihole
    Mar 24 23:51:48 raspberrypi su[878]: pam_unix(su:session): session opened for user pihole by (uid=0)
    Mar 24 23:51:48 raspberrypi pihole-FTL[323]: /usr/bin/pihole-FTL: 1: /usr/bin/pihole-FTL: Syntax error: redirection unexpected
    Mar 24 23:51:48 raspberrypi systemd[1]: Started LSB: pihole-FTL daemon.
0 Likes

#10

Is everything working?

0 Likes

#11

No, the admin webpage still says “Lost Connection to API”, shows the DNS Service and FTL as not running, and doesnt show a version number at all for FTL at the bottom right

0 Likes

#12

Okay, what does pihole -v show? And run another debug if you could please.

0 Likes

#13

And just to make sure things are in the right place, try pihole -r and repair.

1 Like

#14
pi@raspberrypi:~ $ pihole -v
  Pi-hole version is v4.2.2 (Latest: ERROR)
  AdminLTE version is v4.2 (Latest: ERROR)
/usr/bin/pihole-FTL: line 1: syntax error near unexpected token `<'
/usr/bin/pihole-FTL: line 1: `<html><body>You are being <a href="https://github-production-release-asset-2e65be.s3.amazonaws.com/80716356/48882a80-3924-11e9-89ab-cddb36b402c4?X-Amz-Algorithm=AWS4-HMAC-SHA256&amp;X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20190324%2Fus-east-1%2Fs3%2Faws4_request&amp;X-Amz-Date=20190324T175844Z&amp;X-Amz-Expires=300&amp;X-Amz-Signature=f3e9da4c391acfb5c198d8db2d5b8128cc4eb33812f06ecdfa525d9e11f4d3b4&amp;X-Amz-SignedHeaders=host&amp;actor_id=0&amp;response-content-disposition=attachment%3B%20filename%3Dpihole-FTL-arm-linux-gnueabihf&amp;response-content-type=application%2Foctet-stream">redirected</a>.</body></html>'
  Latest FTL version is ERROR

The debug log was having an error while uploading again. I had to change the resolv.conf to google’s DNS again, and this time I got

https://tricorder.pi-hole.net/d9qhozbgfv!

0 Likes

#15

Okay, run pihole -r the curl command pulled down the text of the web page instead of the actual binary file.

1 Like

#16

It seems to have gotten stuck at

  [i] Downloading and Installing FTL...

again. It has been on that for the past 10 minutes.

EDIT:

  [i] Downloading and Installing FTL...curl: (56) SSL read: error:00000000:lib(0):func(0):reason(0), errno 104
  [✗] Downloading and Installing FTL
  Error: URL https://github.com/pi-hole/FTL/releases/download/v4.2.3/pihole-FTL-arm-linux-gnueabihf not found
  [✗] FTL Engine not installed
0 Likes

#17

I think I may have fixed it.

I downloaded the binary from https://github.com/pi-hole/FTL/releases/download/v4.2.3/pihole-FTL-arm-linux-gnueabihf on another device, renamed it to “pihole-FTL”, moved it over to /tmp/ using SFTP. Then I did, in order:

sudo mv /tmp/pihole-FTL /usr/bin/
sudo reboot
sudo chmod 755 /usr/bin/pihole-FTL
sudo chown root:root /usr/bin/pihole-FTL
sudo service pihole-FTL start
sudo nano /etc/resolv.conf

changed the IP to 8.8.8.8

pihole -r

Now it seems to be working. I’m guessing Github’s servers in my location are probably having a few issues.

0 Likes

closed #18

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes