Unable to Enable Pi Hole DHCP Server. Internet Access Lost


#1

I’ve just installed Pi Hole. It has not been the smoothest of installs, lighttpd did not install correctly preventing me from accessing the web interface.

My router (a Plusnet Hub One) does not allow the setting of custom DNS servers so I would like to use the Pi Hole DHCP server.

I enable this in the web interface with the settings below:
From 192.168.0.64 to 192.168.0.254
Gateway 192.168.0.1

I click the save button and am presented with a notification along the top of the page that ‘the DHCP server has been activated (IPv4)’.

Nothing seems to be working. My RPi (running Debian Wheezy) has lost internet connectivity as a result of this.

Any help!?


#2

Did you disable the router’s DHCP server? Try restarting your devices, as they need to renew their DHCP license.


#3

See also: