Unable to connect to internet when setting pihole as DNS

The issue I am facing:
When ever I set pihole as my dns on my router nothing is able to connect to the internet. I have fixed the ip address of the Rpi.

Details about my system:
My raspberry pi is running homebridge image with pihole, trying to set it up on an ASUS router.

My debug token is: https://tricorder.pi-hole.net/PgHVGCuA/

What I have changed since installing Pi-hole:

Nothing

Your debug log shows your Pi-hole to be fully operational.

Lucky enough, it even contains the stats to confirm that it has been receiving, filtering and replying a substantial number of DNS requests for quite a number of clients in your network (which seems to contradict your statement that 'nothing is able to connect to the internet'):

   [2023-09-15 21:29:32.641 3077M] Imported 13643 queries from the long-term database
   [2023-09-15 21:29:32.641 3077M]  -> Total DNS queries: 13643
   [2023-09-15 21:29:32.641 3077M]  -> Cached DNS queries: 3489
   [2023-09-15 21:29:32.641 3077M]  -> Forwarded DNS queries: 9179
   [2023-09-15 21:29:32.642 3077M]  -> Blocked DNS queries: 746
   [2023-09-15 21:29:32.642 3077M]  -> Unknown DNS queries: 2
   [2023-09-15 21:29:32.642 3077M]  -> Unique domains: 710
   [2023-09-15 21:29:32.642 3077M]  -> Unique clients: 29
   [2023-09-15 21:29:32.642 3077M]  -> Known forward destinations: 2

What error messages do you see on a client that make you assume that Pi-hole would be causing Internet failures?
Could you give an example of a failed DNS resolution attempt of such a client?

And run from a client that you observe to be unable to connect to the Internet, what is the result of the following commands:

nslookup pi.hole
nslookup time.nest.com
nslookup flurry.com
1 Like

I think I’ve solved it, I am using apple devices and it was something to do with having iCloud private relay turned on, now I’ve disabled it everything seems to be working fine.

Do you know if there is a way to have private relay enabled and still use pihole?

No, you can only have one or the other.

However, it should be possible to leave Private Relay enabled and switch it off only when connected to your home wifi network.

I'd even expect that to work that way automatically, as Pi-hole would by default signal Apple devices that Private Relay should be disabled (see Pi-hole's documentation on BLOCK_ICLOUD_PR for details).
You'd usually see a corresponding message on your Apple device when connecting to a Pi-hole operated network for the first time.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.