Unable to add to whitelist

Please follow the below template, it will help us to help you!

Expected Behaviour:

I should be able to add URLs to whitelist. I had been able to in the past.

Actual Behaviour:

Error, something went wrong!
While executing: attempt to write a readonly database
Added 0 out of 1 domains

Debug Token:

https://tricorder.pi-hole.net/ze0evhbs35

You can add domains to the whitelist, but not URL's. If you try to enter a URL, you will receive an error.

From your debug log, you are running Apache, which is an unsupported web server. I have moved this post to the Community Help forum.

*** [ DIAGNOSING ]: Ports in use
*:9090 systemd (IPv6)
[80] is in use by httpd (https://docs.pi-hole.net/main/prerequisites/#ports)
*:443 httpd (IPv6)
*:22 sshd (IPv4)
*:22 sshd (IPv6)
*:3306 mysqld (IPv6)
[80] is in use by httpd (https://docs.pi-hole.net/main/prerequisites/#ports)
*:443 httpd (IPv6)
[80] is in use by httpd (https://docs.pi-hole.net/main/prerequisites/#ports)
*:443 httpd (IPv6)
[80] is in use by httpd (https://docs.pi-hole.net/main/prerequisites/#ports)

*** [ DIAGNOSING ]: Dashboard and block page
[✗] Block page X-Header: X-Header does not match or could not be retrieved.
HTTP/1.1 403 Forbidden
Date: Fri, 20 Nov 2020 18:18:56 GMT
Server: Apache/2.4.46 (Fedora) OpenSSL/1.1.1g
Last-Modified: Thu, 25 Jul 2019 05:18:03 GMT
ETag: "15bc-58e7a8ccdb8c0"
Accept-Ranges: bytes
Content-Length: 5564
Content-Type: text/html; charset=UTF-8

I get the following:

[tmorgenthaler@galactica ~]$ sudo usermod -a -G pihole www-data
[sudo] password for tmorgenthaler:
usermod: user 'www-data' does not exist

Funny thing, this all worked in the original release of pihole 5.0. It worked in 4.x as well. All I did was the upgrades.

Your debug log expired, please generate a new one. Do you use Apache as web server?

https://tricorder.pi-hole.net/pcbzj4tjol

Yes, I do use Apache for other things on my server.

You need to find out under which user apache is running on your system and add it to the group pihole as shown above. Replace www-data accordingly.
See here how to find the right username

The user is apache. I added it, restarted apachectl, and I'm still experiencing the same problem. Any other ideas?

No, sorry. I'm not using apache. Try searching the forum.