Turning off router DCHP

I have a Nowtv router which I am unable to turn off the DCHP setting.It is selectable but after router reboot just turns back on again.
I have been able to configure the pi-hole OK.
Help- newbie.

Why do you want or need to disable router DHCP?

Even if you cannot turn off router DHCP, there are some workarounds where you can run DHCP on both.

As I understand it,from the pi-hole setup instructions,the router DCHP needs turning off and the pi-hole DCHP needs to be enabled.

This is not the case. Many users (me included) have the router serve DHCP and the router assigns the Pi-hole as DNS.

Using the Pi-hole DHCP server is optional.

I am unable to use the router LAN settings option so opted for DCHP configuration.

The DCHP option states-

To Use Pi-hole’s DHCP Server

  1. Disable the DHCP server on your router (this is a critical stepyou will see red warning text when you enable the checkbox)
  2. Enable Pi-hole’s DHCP server on the Settings page

As previously mentioned I cannot disable the router DCHP option.

Instead of disabling the router DHCP, which you cannot do, change the IP range of the router DHCP server to a single IP, and make that the same as the static IP of the Pi-hole.

Then, activate DHCP on the Pi-hole, set the IP range to a range that doesn't overlap the router IP range. Reboot the router, renew the DHCP lease on all clients, and you should be set.

I have changed the IP range of my router to match that of Pi-hole and set the static address of the Pi-hole within that range.

Now working OK although blocking rate is only 9.5% but I believe that will improve with time.

Thank you for the Solution and prompt replies.

1 Like