Top Clients - Only IP's shown?

I updated my Pi-hole 5.x to development-v6 yesterday.
Now the dashboard is only showing IP's not DNS names as in 5.x where all DNS names were correctly shown for both Top and Blocked clients.
All client names are visible/readable on DHCP page but not on dashboard...

Any setting I should change to make this work again?


Thanks in advance!!

Sorry for the delay in replying. Are you using your Pi-hole also as DHCP server?

If so, could you log into your Pi-hole using SSH and run

dig -x @

What is the output?

Yes Pi-hole is managing both DHCP and DNS.


; <<>> DiG 9.18.19-1~deb12u1-Debian <<>> -x @
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24553
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 1232

;; ANSWER SECTION: 0 IN PTR Jockes_M10_Plus.groupwork.

;; Query time: 0 msec
;; WHEN: Mon Jan 29 07:08:58 CET 2024
;; MSG SIZE rcvd: 93

(The IP belongs to an old-ish Android tablet)

Installation is updated from 5.x (latest available ~2 weeks ago) to 6.x dev.


This shows that - in theory - local name resolution does work as expected. Also your resolver settings are as default per your debug log. Unfortunately, this means we need to dive a bit deeper, but that won't be a problem.

Please start off with

sudo service pihole-FTL stop
sudo pihole-FTL --config debug.resolver true
sudo rm /var/log/pihole/FTL.log
sudo service pihole-FTL start

After a few minutes, go to /var/log/pihole/FTL.log and check for messages beginning with DEBUG_RESOLVER. Without knowing what is causing the issue, I cannot really say what to look out for but maybe you can simply provide some of those lines here and we can check together. You can also send them to my via a private message if you prefer this for privacy reasons.

Thanks a lot for helping!

Log (snip) sent.
Stopped logging with:

sudo service pihole-FTL stop
sudo pihole-FTL --config debug.resolver false
sudo rm /var/log/pihole/FTL.log
sudo service pihole-FTL start

That's enough?

Yes. And thanks for the log file.

Interestingly your log shows an issue I thought has been fixed a long time ago, but it appears

is still in the reviewing process.

Please try running

pihole checkout ftl fix/resolver

and see if this fixes the issue you are seeing.

1 Like

Big thanks, issue solved immeditely! :upside_down_face:

1 Like

The fix has passed review process and is now included in development-v6. You should go back over there to continue receiving further updates. Thanks for confirming that this PR solved the issue for you. One could only assume that this confirmation is what suddenly made the review process going again :slight_smile:

1 Like